HWKMETRICS-420 refactored the AvailabilityBucketPoint class to include some new fields, one of which is durationMap which is a mapping of availability types to their respective durations. In its serialized JSON form it looks like,
We should be just using the string codes - up, down, unknown, admin. The above JSON would instead be
This would be consistent with what we expect for inserting availability data points, and it also keeps implementation details hidden. Jay Shaughnessy do you see any problems with this change?