Uploaded image for project: 'Hawkular Metrics'
  1. Hawkular Metrics
  2. HWKMETRICS-359

Upgrade Cassandra driver to 3.0.0

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 0.14.0
    • Component/s: Core
    • Labels:
      None

      Description

      The versions of Cassandra and the driver have already been bumped in the Hawkular parent pom, but we are not quite ready to move to Cassandra 3.x yet as we need to make sure we have a clear upgrade path for OpenShift installs. We can however go ahead and upgrade the driver to version 3.0.0 as it is backwards compatible with earlier versions of Cassandra.

      There is another reason I want to go ahead and upgrade the driver now. The schema change management tool I am working on requires version 3.0.0 of the driver so that it can support version 2.x and 3.x of Cassandra.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                john.sanda John Sanda
                Reporter:
                john.sanda John Sanda
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: