Uploaded image for project: 'Fuse Tools'
  1. Fuse Tools
  2. FUSETOOLS-762

Null Pointer Exception creating fabric container via SSH

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: 2.1.0
    • Fix Version/s: 7.1.0
    • Labels:
      None

      Description

      Trying to create a container results in the following message:

      Failed to create container: org.fusesource.fabric.api.FabricException: java.lang.NullPointerException

      Going to the error log reveals this stack trace:

      org.fusesource.fabric.api.FabricException: java.lang.NullPointerException
      at org.fusesource.fabric.service.ssh.SshContainerProvider.create(SshContainerProvider.java:96)
      at org.fusesource.fabric.service.ssh.SshContainerProvider.create(SshContainerProvider.java:46)
      at org.fusesource.fabric.service.FabricServiceImpl.createContainers(FabricServiceImpl.java:258)
      at com.fusesource.ide.fabric.navigator.Fabric$3.run(Fabric.java:396)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
      Caused by: java.lang.NullPointerException
      at java.lang.String.<init>(String.java:147)
      at org.fusesource.fabric.service.ssh.SshContainerProvider.create(SshContainerProvider.java:73)
      ... 4 more

        Gliffy Diagrams

          Activity

          tsedmik Tomáš Sedmík added a comment -

          verified - JBDSIS 8.0.2.GA


            People

            • Assignee:
              lvaldez1 Luis Valdez
              Reporter:
              jrawlings1980 James Rawlings
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: