Uploaded image for project: 'Forge'
  1. Forge
  2. FORGE-875

the `scaffold setup --scaffoldType faces;` command. failed to create beans.xml

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Critical
    • Resolution: Out of Date
    • Affects Version/s: 1.2.2.Final
    • Fix Version/s: 2.0.0.Beta4
    • Component/s: Scaffold, UI - Eclipse
    • Labels:
    • Environment:

      Mac: OS X 10.8.3, 2.66 GHz Intel Core i7, 4GG 1067 MHz DDR3
      Running Forge Console in JBoss Developers Studio version 6.1.0.GA, Deploying to JBoss EAP 6.0.1

    • Workaround Description:
      Hide

      Added "beans setup" to generate.fsh file

      Show
      Added "beans setup" to generate.fsh file

      Description

      I generated a sample project using the generate.fsh script. I deployed the war file to EAP 6 and everything seemed to be working fine.

      The welcome page comes up for the app with no problems. However, an error is generated upon the attempt to add data to the database.

      I was able to resolve the problem by adding the following lines to the script:
      @/* Add beans.xml for CDI */;
      touch src/main/webapp/WEB-INF/beans.xml

      Lincoln indicated that this should have already been done by the
      `scaffold setup --scaffoldType faces;` command.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                koen.aers Koen Aers
                Reporter:
                randythomas Randy Thomas
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: