Uploaded image for project: 'Fabric8'
  1. Fabric8
  2. FABRIC-5

Add in the fabric feature files the bundles required to deploy fabric-camel, ....

    Details

    • Type: Enhancement
    • Status: Resolved
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.1-old
    • Component/s: None
    • Labels:
      None

      Description

      When we deploy fabric-camel, they are dependencies issues (scala is missing, gogo command error). So improving features file will be great

      [  43] [Active     ] [            ] [       ] [   60] fabric-util (1.0.0.SNAPSHOT)
      [  44] [Active     ] [Created     ] [       ] [   60] fabric-zookeeper (1.0.0.SNAPSHOT)
      [  45] [Active     ] [Created     ] [       ] [   60] fabric-commands (1.0.0.SNAPSHOT)
      [  46] [Active     ] [Created     ] [       ] [   60] fabric-configadmin (1.0.0.SNAPSHOT)
      [  47] [Installed  ] [            ] [       ] [   60] fabric-camel (1.0.0.SNAPSHOT)
       
      Error executing command: Unresolved constraint in bundle org.fusesource.fabric.fabric-camel [47]: Unable to resolve 47.0: missing requirement [47.0] package; (package=scala)
       
      karaf@root> start 47
      Error executing command: Constraint violation for package 'org.fusesource.jansi' when resolving module 47.0 between existing export 47.0.org.fusesource.jansi NO BLAME and uses constraint 22.0.org.fusesource.jansi BLAMED ON [[47.0] package; (&(package=org.apache.felix.gogo.commands)(version>=0.6.0)(!(version>=1.0.0)))]

        Gliffy Diagrams

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Unassigned
              Reporter:
              cmoulliard Charles Moulliard
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development