FUSE ESB
  1. FUSE ESB
  2. ESB-1732

Missing messages under XA transactions

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Done
    • Affects Version/s: 4.4.1-fuse-07-11
    • Fix Version/s: 4.4.1-fuse-08-15
    • Component/s: Core
    • Labels:
      None
    • Environment:
      tested using apache-servicemix-4.4.1-fuse-07-11 with apache-activemq-5.5.1-fuse-07-11

    • Similar Issues:
      Show 5 results 

      Description

      When I used the test case attached to MB-1181 on windows XP running on dual core machine (2.53GHz) I noted that 10-30 of the 10,000 messages where not present on the out queue ("ESB_OUT").

      When the testcase was run on macbook pro running"Mac OS X Lion 10.7.2" on a 4 core 2.3 GHz processor I consistently got all expected messages on the outgoing queue.

        Issue Links

          Activity

          Gary Tully
          added a comment -

          TRACE level logging of org.apache.geronimo.transaction.manager.RecoveryImpl will help point to the problem.

          I think the root cause is a call to recover on the broker. it will return all prepared transactions, irrespective if they were inboubt from recovery or from current in progress transactions.
          the TM, sees the xid and does not have a reference to it so it calls rollback. Then the commit fails.

          Need to check what is the correct behavior here. I think the Tm should only recover or complete what it knows about, what it knows it has an outcome for. Or the broker needs to filter recovery from in progress in some way.

          Show
          Gary Tully
          added a comment - TRACE level logging of org.apache.geronimo.transaction.manager.RecoveryImpl will help point to the problem. I think the root cause is a call to recover on the broker. it will return all prepared transactions, irrespective if they were inboubt from recovery or from current in progress transactions. the TM, sees the xid and does not have a reference to it so it calls rollback. Then the commit fails. Need to check what is the correct behavior here. I think the Tm should only recover or complete what it knows about, what it knows it has an outcome for. Or the broker needs to filter recovery from in progress in some way.
          Show
          Pat Fox
          added a comment - From our initial testing it appears the following snapshot fixes this issue http://repo.fusesource.com/nexus/content/repositories/snapshots/org/apache/aries/transaction/org.apache.aries.transaction.manager/0.3.1.fuse-7-0-x-SNAPSHOT/org.apache.aries.transaction.manager-0.3.1.fuse-7-0-x-20120709.095949-3.jar
          Gary Tully
          added a comment -

          fix to Geronimo generation and matching of global and branch xids on: ssh://git@forge.fusesource.com/aries.git
          589166a..6b9d299 0.3.1.fuse-7-0-x-stable -> 0.3.1.fuse-7-0-x-stable

          snapshot: http://repo.fusesource.com/nexus/content/repositories/snapshots/org/apache/aries/transaction/org.apache.aries.transaction.manager/0.3.1.fuse-7-0-x-SNAPSHOT/org.apache.aries.transaction.manager-0.3.1.fuse-7-0-x-20120709.095949-3.jar

          Show
          Gary Tully
          added a comment - fix to Geronimo generation and matching of global and branch xids on: ssh://git@forge.fusesource.com/aries.git 589166a..6b9d299 0.3.1.fuse-7-0-x-stable -> 0.3.1.fuse-7-0-x-stable snapshot: http://repo.fusesource.com/nexus/content/repositories/snapshots/org/apache/aries/transaction/org.apache.aries.transaction.manager/0.3.1.fuse-7-0-x-SNAPSHOT/org.apache.aries.transaction.manager-0.3.1.fuse-7-0-x-20120709.095949-3.jar
          Torsten Mielke
          added a comment -

          Fixed by Aries patch. Confirmed by customer.

          Show
          Torsten Mielke
          added a comment - Fixed by Aries patch. Confirmed by customer.

            People

            • Assignee:
              Gary Tully
              Reporter:
              Pat Fox
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: