FUSE ESB
  1. FUSE ESB
  2. ESB-1704

Dependency conflict when installing camel-hdfs component

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 4.4.1-fuse-03-06
    • Fix Version/s: 4.4.1-fuse-07-11
    • Component/s: None
    • Labels:
      None
    • Environment:
      Fuse ESB 4.4.1-03-06
    • Similar Issues:
      Show 10 results 

      Description

      Hitting a problem trying to install camel-hdfs component, due to a conflict on the org.apache.commons.codec.binary package.

      karaf@root> features:list | grep camel-hdfs
      [uninstalled] [2.8.0-fuse-03-06    ] camel-hdfs                           camel-2.8.0-fuse-03-06            
      karaf@root> features:install camel-hdfs
      Error executing command: Could not start bundle mvn:org.apache.camel/camel-hdfs/2.8.0-fuse-03-06 in feature(s) camel-hdfs-2.8.0-fuse-03-06: Unable to resolve module org.apache.servicemix.bundles.hadoop-core [239.0] because it is exposed to package 'org.apache.commons.codec.binary' from org.apache.commons.codec [249.0] and org.apache.servicemix.bundles.commons-codec [55.0] via two dependency chains.
      
      Chain 1:
        org.apache.servicemix.bundles.hadoop-core [239.0]
          import: (&(package=org.apache.commons.codec.binary)(version>=1.4.0)(!(version>=2.0.0)))
           |
          export: package=org.apache.commons.codec.binary
        org.apache.commons.codec [249.0]
      
      Chain 2:
        org.apache.servicemix.bundles.hadoop-core [239.0]
          import: (package=org.apache.commons.httpclient)
           |
          export: package=org.apache.commons.httpclient; uses:=org.apache.commons.codec.net
        org.apache.servicemix.bundles.commons-httpclient [176.0]
          import: (&(package=org.apache.commons.codec.net)(version>=1.3.0)(!(version>=2.0.0)))
           |
          export: package=org.apache.commons.codec.net; uses:=org.apache.commons.codec.binary
          export: package=org.apache.commons.codec.binary
        org.apache.servicemix.bundles.commons-codec [55.0]
      karaf@root> 
      
      

        Activity

        Hide
        Willem Jiang
        added a comment -

        servicemix installs commons-codec 1.3.0-3 when install the activemq-karaf feature, it cause some trouble for hadoop-core bundle which has a lowers dependency on commons-codec 1.4.0.
        As this dependency is introduced by apache commons-httpclient, we should be safe to use commons-codec 1.3.0_3 in this case.

        So I create a SMX4-1138 to change the version rage.
        We also need to update the apache-camel feature once the new bundle is released.

        The work around could be uninstall the osgi bundle 55, and then install camel-hdfs , and restart other related bundles

        Show
        Willem Jiang
        added a comment - servicemix installs commons-codec 1.3.0-3 when install the activemq-karaf feature, it cause some trouble for hadoop-core bundle which has a lowers dependency on commons-codec 1.4.0. As this dependency is introduced by apache commons-httpclient, we should be safe to use commons-codec 1.3.0_3 in this case. So I create a SMX4-1138 to change the version rage. We also need to update the apache-camel feature once the new bundle is released. The work around could be uninstall the osgi bundle 55, and then install camel-hdfs , and restart other related bundles
        Hide
        Gert Vanthienen
        added a comment -

        Fixed by upgrading to the new Hadoop bundle version in the 2.8.x-fuse branch in http://fusesource.com/forge/git/camel.git/?p=camel.git;a=commit;h=ea87bbcfbebe6d96ff9413f298037efa763aeb9f

        Show
        Gert Vanthienen
        added a comment - Fixed by upgrading to the new Hadoop bundle version in the 2.8.x-fuse branch in http://fusesource.com/forge/git/camel.git/?p=camel.git;a=commit;h=ea87bbcfbebe6d96ff9413f298037efa763aeb9f

          People

          • Assignee:
            Willem Jiang
            Reporter:
            Dave Stanley
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: