FUSE ESB
  1. FUSE ESB
  2. ESB-1639

NPE is generated within the CxfBcConsumer validate method

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 3.6.0-fuse-00-35
    • Fix Version/s: 3.6.0-fuse-xx-00
    • Component/s: None
    • Labels:
      None
    • Environment:
      esb 3.6.0-fuse-00-35
    • Similar Issues:
      Show 9 results 

      Description

      Upon updating the cxf-wsdl-first example to include a xsd schema within the person.wsdl and using the jax-ws-catalog.xml file to process the schemas locally instead of going to the internet.

      The deployment of the updated example will cause a NPE within the CxfBcConsumer validate method:

      Here is the stack trace:

      javax.jbi.management.DeploymentException: java.lang.NullPointerException
      	at org.apache.servicemix.cxfbc.CxfBcConsumer.validate(CxfBcConsumer.java:566)
      	at org.apache.servicemix.common.AbstractDeployer.validate(AbstractDeployer.java:58)
      	at org.apache.servicemix.common.xbean.BaseXBeanDeployer.validate(BaseXBeanDeployer.java:57)
      	at org.apache.servicemix.common.xbean.AbstractXBeanDeployer.deploy(AbstractXBeanDeployer.java:96)
      	at org.apache.servicemix.common.BaseServiceUnitManager.doDeploy(BaseServiceUnitManager.java:86)
      	at org.apache.servicemix.common.BaseServiceUnitManager.deploy(BaseServiceUnitManager.java:69)
      	at org.apache.servicemix.jbi.framework.DeploymentService.deployServiceAssembly(DeploymentService.java:520)
      	at org.apache.servicemix.jbi.framework.AutoDeploymentService.updateServiceAssembly(AutoDeploymentService.java:349)
      	at org.apache.servicemix.jbi.framework.AutoDeploymentService.updateArchive(AutoDeploymentService.java:255)
      	at org.apache.servicemix.jbi.framework.AutoDeploymentService.monitorDirectory(AutoDeploymentService.java:658)
      	at org.apache.servicemix.jbi.framework.AutoDeploymentService.access$800(AutoDeploymentService.java:63)
      	at org.apache.servicemix.jbi.framework.AutoDeploymentService$1.run(AutoDeploymentService.java:622)
      	at java.util.TimerThread.mainLoop(Timer.java:512)
      	at java.util.TimerThread.run(Timer.java:462)
      Caused by: java.lang.NullPointerException
      	at org.apache.servicemix.cxfbc.CxfBcConsumer.validate(CxfBcConsumer.java:437)
      	... 13 more
      

      The updated example will be attached to this issue.

      I have not tested using the latest version of the 3.6.0 release nor the latest release of 4.4.1.

        Issue Links

          Activity

          Claudio Corsi
          added a comment -

          This is the updated cxf-wsdl-first example that will reproduce this issue.

          You just need to build and deploy it and the exception will be generated during the deploy process.

          Show
          Claudio Corsi
          added a comment - This is the updated cxf-wsdl-first example that will reproduce this issue. You just need to build and deploy it and the exception will be generated during the deploy process.

            People

            • Assignee:
              Freeman(Yue) Fang
              Reporter:
              Claudio Corsi
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: