FUSE ESB
  1. FUSE ESB
  2. ESB-1013

Camel CXF Producer does not work when deployed in JBI SU

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 4.2.0.0M1-fuse, 4.1.0-psc-01-00M2
    • Fix Version/s: 4.1.0-psc-01-00RC1
    • Component/s: servicemix-camel
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      CamelCXF component gets a NoConduitInitiator found exception if deployed inside JBI SU. A complete test SA will be attached shortly

        Activity

        deleted user
        added a comment -

        1. install SMX 4.2-fuse-SNAPSHOT
        2. Unzip the project
        3. Build it starting from the root, the result is a camelcxf-smxcxf-sa.zip in
        camelcxfproblem/jbi/camelcxf-smxcxf/camelcxf-smxcxf-sa/target/camelcxf-smxcxf-sa.zip

        This JBI SA consists of a number of SUs (see camelcxfproblem/jbi/camelcxf-smxcxf/) but the SU of interest is
        camelcxf-smxcxf-camel1-su. The route is supposed to work as follows :

        • an http message is picked up from an http jbi endpoint (see camelcxf-smxcxf-http-su) and is forwarded to a remote addess using a
          camelcxf component. This request will be handled by cxfbc, cxfse and eip SUnits and the response will be forwarded to
          log:soapresponse. Camel context also declares another route. But at the moment the first route does not work (camelcxf)
          due to NoConduitInitiator...

        4. So, to reproduce an issue, just drop this SA into /deploy folder and then start camelcxfproblem//client.html and send a SOAP
        message, and you'll see the exception...

        Note that I've commented <import> statements in camelcxf-smxcxf-camel1-su xbean.xml (and corresponding deps in
        camelcxfproblem/jbi/camelcxf-smxcxf/camelcxf-smxcxf-camel1-su/pom.xml), just for you to start from where I started. I've tried with
        imports too but it did nnot make any difference

        Show
        deleted user
        added a comment - 1. install SMX 4.2-fuse-SNAPSHOT 2. Unzip the project 3. Build it starting from the root, the result is a camelcxf-smxcxf-sa.zip in camelcxfproblem/jbi/camelcxf-smxcxf/camelcxf-smxcxf-sa/target/camelcxf-smxcxf-sa.zip This JBI SA consists of a number of SUs (see camelcxfproblem/jbi/camelcxf-smxcxf/) but the SU of interest is camelcxf-smxcxf-camel1-su. The route is supposed to work as follows : an http message is picked up from an http jbi endpoint (see camelcxf-smxcxf-http-su) and is forwarded to a remote addess using a camelcxf component. This request will be handled by cxfbc, cxfse and eip SUnits and the response will be forwarded to log:soapresponse. Camel context also declares another route. But at the moment the first route does not work (camelcxf) due to NoConduitInitiator... 4. So, to reproduce an issue, just drop this SA into /deploy folder and then start camelcxfproblem//client.html and send a SOAP message, and you'll see the exception... Note that I've commented <import> statements in camelcxf-smxcxf-camel1-su xbean.xml (and corresponding deps in camelcxfproblem/jbi/camelcxf-smxcxf/camelcxf-smxcxf-camel1-su/pom.xml), just for you to start from where I started. I've tried with imports too but it did nnot make any difference
        Show
        deleted user
        added a comment - See https://issues.apache.org/activemq/browse/SMX4-422
        deleted user
        added a comment -

        Great stuff, thanks Willem

        Show
        deleted user
        added a comment - Great stuff, thanks Willem
        Willem Jiang
        added a comment -
        Show
        Willem Jiang
        added a comment - Please see my comments on https://issues.apache.org/activemq/browse/SMX4-422
        Willem Jiang
        added a comment -

        Submit the patch to SMX4-422 with updating the system properties of cxf BusFactory.

        org.apache.cxf.bus.factory=org.apache.cxf.bus.spring.SpringBusFactory
        

        Will close this issue, after the patch is synced into the Fuse repository.

        Show
        Willem Jiang
        added a comment - Submit the patch to SMX4-422 with updating the system properties of cxf BusFactory. org.apache.cxf.bus.factory=org.apache.cxf.bus.spring.SpringBusFactory Will close this issue, after the patch is synced into the Fuse repository.
        Willem Jiang
        added a comment -

        This issue should be fix with CAMEL-2216 in camel-cxf.

        Show
        Willem Jiang
        added a comment - This issue should be fix with CAMEL-2216 in camel-cxf.

          People

          • Assignee:
            Willem Jiang
            Reporter:
            deleted user
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: