Uploaded image for project: 'Errai'
  1. Errai
  2. ERRAI-778

can not start Visual Bus Monitor in errai-tutorial thru gwt-maven-plugin way

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 3.1.0.CR1
    • Component/s: None
    • Labels:
      None
    • Environment:

      Fedora 17
      openjdk 7
      maven 3.0.5
      WildFly-8.0.0.Final

      Description

      I'm trying to start Visual Bus Monitor in errai-tutorial project (https://github.com/errai/errai-tutorial) thru configuration in gwt-maven-plugin by adding Derrai.jboss.javaopts=" Derrai.tools.bus_monitor_attach=true -Djava.awt.headless=false" in <extraJvmArgs>. The final configuration is as below:

      <configuration>
      <extraJvmArgs>Xmx712m -XX:CompileThreshold=7000 -XX:MaxPermSize=128M -Derrai.jboss.home=${errai.jboss.home} -Derrai.dev.context=${errai.dev.context} -Derrai.jboss.javaagent.path=${settings.localRepository}/org/jboss/errai/errai-client-local-class-hider/${errai.version}/errai-client-local-class-hider${errai.version}.jar -Derrai.jboss.javaopts="-Derrai.tools.bus_monitor_attach=true -Djava.awt.headless=false"</extraJvmArgs>
      <logLevel>INFO</logLevel>
      <noServer>false</noServer>
      <server>org.jboss.errai.cdi.server.gwt.JBossLauncher</server>
      <disableCastChecking>true</disableCastChecking>
      <runTarget>${errai.dev.context}/index.html</runTarget>
      <soyc>false</soyc>
      <hostedWebapp>src/main/webapp</hostedWebapp>
      </configuration>

      by doing this, the development mode window can show up, but the Visual Monitor Bus still can not show up.

      BTW, i have added the errai-tools as a runtime dependency in pom.xml as below:

      <dependency>
      <groupId>org.jboss.errai</groupId>
      <artifactId>errai-tools</artifactId>
      <version>${errai.version}</version>
      <scope>runtime</scope>
      </dependency>

      So still need some any other configuration to make it show up?

      BTW, i've also tried to start it in cli as below:
      mvn clean gwt:run -Derrai.tools.bus_monitor_attach=true -Djava.awt.headless=false

      But still can not work.

      FYI, this -Djava.awt.headless=false configuration is got from the blog here:http://errai-blog.blogspot.com/2010/03/visual-bus-monitor.html.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                mbarkley Max Barkley
                Reporter:
                ligangty Gang Li
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: