Uploaded image for project: 'Errai'
  1. Errai
  2. ERRAI-746

Errai marshalling causes compile errors with latest GWT 2.7 SNAPSHOT

    XMLWordPrintable

    Details

    • Type: Enhancement
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 3.0.0.CR1
    • Fix Version/s: 3.0.0.Final
    • Component/s: ErraiMarshalling
    • Labels:
      None
    • Environment:

      Errai 3.0.0.CR1 compiled with latest GWT 2.7 SNAPSHOT

      Description

      Compiling an application using errai-marshalling with the latest GWT 2.7 SNAPSHOT causes the follwing compilation errors when compiling with -strict flag:

      Validating units:
      [ERROR] Errors in 'org/jboss/errai/marshalling/client/util/ArraysUtil.java'
      [ERROR] Line 103: Referencing method 'com.google.gwt.lang.Array.initDims([Ljava/lang/Class;[Lcom/google/gwt/core/client/JavaScriptObject;[I[III)': unable to resolve method in class 'com.google.gwt.lang.Array'
      [ERROR] Line 115: Referencing field 'java.lang.Class.seedId': unable to resolve field in class 'java.lang.Class'
      [ERROR] Line 122: Referencing method 'com.google.gwt.lang.Array.initValues(Ljava/lang/Class;Lcom/google/gwt/core/client/JavaScriptObject;ILcom/google/gwt/lang/Array': unable to resolve method in class 'com.google.gwt.lang.Array'
      [ERROR] Aborting compile due to errors in some input files
      :compileGwt FAILED

      Compiling with 2.5.1 and 2.6.1 works without errors.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                csa Christian Sadilek
                Reporter:
                faxe13 Gert Kropiunik
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: