Errai
  1. Errai
  2. ERRAI-600

Deploy to Nexus hangs when Generating Mashallers Bootstrapper

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Cannot Reproduce Bug
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Build and Common
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      When deploying to Nexus [mvn clean install -Dfull -DskipTests] the deploy hangs in one project when Generating Marshallers Bootstrapper . . .
      This happens occasionally.
      The project is: https://github.com/droolsjbpm/jbpm-console-ng
      I dont know how to explain how to reproduce it - since it happens occasionally.

      The error message is:

      [INFO]
      [INFO] ------------------------------------------------------------------------
      [INFO] Building jBPM Console NG - Showcase 6.0.0.CR1
      [INFO] ------------------------------------------------------------------------
      [WARNING] The POM for jbpt:jbpt:jar:0.1.0 is missing, no dependency information available
      [WARNING] The POM for org.supercsv:SuperCSV:jar:1.52 is missing, no dependency information available
      [INFO]
      [INFO] — maven-clean-plugin:2.4.1:clean (default-clean) @ jbpm-console-ng-showcase —
      [INFO] Deleting /home/mbiarnes/Development/git/droolsjbpm/jbpm-console-ng/jbpm-console-ng-showcase/target
      [INFO] Deleting /home/mbiarnes/Development/git/droolsjbpm/jbpm-console-ng/jbpm-console-ng-showcase (includes = [.errai/**, .niogit/**], excludes = [])
      [INFO]
      [INFO] — gwt-maven-plugin:2.5.0:clean (gwt-clean) @ jbpm-console-ng-showcase —
      [INFO]
      [INFO] — maven-enforcer-plugin:1.2:enforce (default) @ jbpm-console-ng-showcase —
      [INFO]
      [INFO] — maven-enforcer-plugin:1.2:enforce (enforce-java-version) @ jbpm-console-ng-showcase —
      [INFO]
      [INFO] — maven-enforcer-plugin:1.2:enforce (enforce-maven-version) @ jbpm-console-ng-showcase —
      [INFO]
      [INFO] — build-helper-maven-plugin:1.7:parse-version (default) @ jbpm-console-ng-showcase —
      [INFO]
      [INFO] — buildnumber-maven-plugin:1.2:create-timestamp (get-build-timestamp) @ jbpm-console-ng-showcase —
      [INFO]
      [INFO] — buildnumber-maven-plugin:1.2:create (get-scm-revision) @ jbpm-console-ng-showcase —
      [INFO]
      [INFO] — jacoco-gwt-maven-plugin:0.5.4.201202141554:prepare-agent (jacoco-gwt-prepare-agent) @ jbpm-console-ng-showcase —
      [INFO] argLine set to -javaagent:/home/mbiarnes/.m2/repository/org/jboss/errai/jacoco-gwt-maven-plugin/0.5.4.201202141554/jacoco-gwt-maven-plugin-0.5.4.201202141554.jar=snapshotDirectory=/home/mbiarnes/Development/git/droolsjbpm/jbpm-console-ng/jbpm-console-ng-showcase/target/snapshot-classes,snapshotClassLoaders=gwt -javaagent:/home/mbiarnes/.m2/repository/org/jacoco/org.jacoco.agent/0.5.4.201111111111/org.jacoco.agent-0.5.4.201111111111-runtime.jar=destfile=/home/mbiarnes/Development/git/droolsjbpm/jbpm-console-ng/jbpm-console-ng-showcase/target/jacoco.exec
      [INFO]
      [INFO] — maven-resources-plugin:2.6:resources (default-resources) @ jbpm-console-ng-showcase —
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] Copying 15 resources
      [INFO] Copying 31 resources
      [INFO]
      [INFO] — gwt-maven-plugin:2.5.0:resources (gwt-compile) @ jbpm-console-ng-showcase —
      [INFO] 12 source files from GWT module org.jbpm.console.ng.jBPMShowcase
      [INFO]
      [INFO] — maven-compiler-plugin:2.5.1:compile (default-compile) @ jbpm-console-ng-showcase —
      [INFO] Compiling 14 source files to /home/mbiarnes/Development/git/droolsjbpm/jbpm-console-ng/jbpm-console-ng-showcase/target/classes
      [INFO]
      [INFO] — maven-resources-plugin:2.6:testResources (default-testResources) @ jbpm-console-ng-showcase —
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] skip non existing resourceDirectory /home/mbiarnes/Development/git/droolsjbpm/jbpm-console-ng/jbpm-console-ng-showcase/src/test/resources
      [INFO]
      [INFO] — maven-compiler-plugin:2.5.1:testCompile (default-testCompile) @ jbpm-console-ng-showcase —
      [INFO] No sources to compile
      [INFO]
      [INFO] — maven-surefire-plugin:2.12.4:test (default-test) @ jbpm-console-ng-showcase —
      [INFO] Tests are skipped.
      [INFO]
      [INFO] — maven-resources-plugin:2.6:copy-resources (copy-resources) @ jbpm-console-ng-showcase —
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] Copying 3 resources
      [INFO]
      [INFO] — gwt-maven-plugin:2.5.0:compile (gwt-compile) @ jbpm-console-ng-showcase —
      [INFO] Compiling module org.jbpm.console.ng.jBPMShowcase
      [ERROR] SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
      [ERROR] SLF4J: Defaulting to no-operation (NOP) logger implementation
      [ERROR] SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
      [INFO] Computing all possible rebind results for 'org.jboss.errai.marshalling.client.api.MarshallerFactory'
      [INFO] Rebinding org.jboss.errai.marshalling.client.api.MarshallerFactory
      [INFO] Invoking generator org.jboss.errai.marshalling.rebind.MarshallersGenerator
      [INFO] Generating Marshallers Bootstrapper...

        Activity

        Christian Sadilek
        added a comment -

        A User in our forum reported a similar issue when building their app using Jenkins on an Amazon server:
        https://community.jboss.org/thread/230707

        We need to look into this for the next release.

        Show
        Christian Sadilek
        added a comment - A User in our forum reported a similar issue when building their app using Jenkins on an Amazon server: https://community.jboss.org/thread/230707 We need to look into this for the next release.
        Christian Sadilek
        added a comment -

        Hi Michael,

        One thing that's worth trying is giving Maven and GWT more memory:

        e.g.

        • export MAVEN_OPTS=-Xmx1g
        • and specify mvn ... -Dgwt.extraJvmArgs="-Xmx768m" on the command line

        Can you give this a try and see if you still experience the problem? The forum thread I quoted above is unrelated I think as it only happens on Errai 2.4.0.

        Cheers,
        Christian

        Show
        Christian Sadilek
        added a comment - Hi Michael, One thing that's worth trying is giving Maven and GWT more memory: e.g. export MAVEN_OPTS=-Xmx1g and specify mvn ... -Dgwt.extraJvmArgs="-Xmx768m" on the command line Can you give this a try and see if you still experience the problem? The forum thread I quoted above is unrelated I think as it only happens on Errai 2.4.0. Cheers, Christian
        Christian Sadilek
        added a comment -

        Just moving this out of 2.4.0.Final since it's not release specific. I could not reproduce the problem with the settings above.

        Show
        Christian Sadilek
        added a comment - Just moving this out of 2.4.0.Final since it's not release specific. I could not reproduce the problem with the settings above.

          People

          • Assignee:
            Unassigned
            Reporter:
            Michael Biarnes Kiefer
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: