Errai
  1. Errai
  2. ERRAI-202

errai-ioc depends on errai-bus, but it shouldn't

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 3.0.0.M1, 2.4.0.Beta1
    • Component/s: None
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      One example of a problem caused by this dependency is that a pure Errai JAX-RS app still ends up creating a client bus and connecting it to the server. This is somewhat confusing, plus it generates unnecessary load on the client and the server.

        Issue Links

          Activity

          Christian Sadilek
          added a comment -

          Resolved in the 3.0 branch.

          Show
          Christian Sadilek
          added a comment - Resolved in the 3.0 branch.

            People

            • Assignee:
              Unassigned
              Reporter:
              Jonathan Fuerth
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: