Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-9975

[Hawtio Spring Boot] Debug attribute is changing its readonly state

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: fuse-7.3
    • Fix Version/s: fuse-7.3
    • Component/s: Hawtio
    • Labels:
      None
    • Environment:

      RHEL 7, Chrome 70.0.3538.67, Fuse Spring Boot 7.3.0.fuse-730012

    • Sprint:
      Fuse 7.3 Sprint 42 - Bug fix
    • Steps to Reproduce:
      Hide

      1. Login to Hawtio
      2. Go to JMX tab
      3. Open jmx4perl -> Config
      4. Go to Attributes tab
      5. Click on Debug attribute
      6. Check, that Value field is editable

      Show
      1. Login to Hawtio 2. Go to JMX tab 3. Open jmx4perl -> Config 4. Go to Attributes tab 5. Click on Debug attribute 6. Check, that Value field is editable

      Description

      The Value field of Debug attribute is sometimes not editable. It's happening mainly after the first login to Hawtio. I didn't find out the pattern when the field is editable and when not, it's just random for me. Sometimes it happens also when I click on other pages and then go back to check the field.

      It's not a major issue for user, he can just close the window and then open it and the field is editable. However, it is very problematic for our automated tests.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                alexkieling Alexandre Kieling
                Reporter:
                lblahuto Lucia Drozdova
                Tester:
                Lucia Drozdova
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: