Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-9869

[camel-rest, camel-swagger-java] Wrong protocol in swagger.json

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: fuse-7.3
    • Component/s: Camel
    • Labels:
      None
    • Sprint:
      Fuse 7.3 Sprint 39

      Description

      I am using (bypassed ENTESB-9868) camel-undertow, camel-swagger-java and REST DSL for creating REST endpoint with API doc. I am using HTTPS protocol. (see attached reproducer). I am getting wrong sheme in swagger.json.

      My output on " https://localhost:4444/swagger.json".

      {
          "swagger": "2.0",
          "info": {
              "description": "Camel Rest App with Swagger",
              "version": "1.0",
              "title": "Rest swagger"
          },
          "host": "localhost:4444",
          "basePath": "/",
          "tags": [
              {
                  "name": "user"
              }
          ],
          "schemes": [
              "http"
          ],
          "paths": {
              "/user": {
                  "get": {
                      "tags": [
                          "user"
                      ],
                      "operationId": "route1",
                      "responses": {
                          "200": {}
                      }
                  }
              }
          }
      }
      

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  oscerd Andrea Cosentino
                  Reporter:
                  jbouska Jan Bouska
                  Tester:
                  Jan Bouska
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: