Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-9736

org.apache.kafka:kafka_2.11:jar:2.0.0.redhat-00003 not built for Camel

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: fuse-7.2
    • Fix Version/s: fuse-7.3
    • Component/s: Camel
    • Labels:
    • Sprint:
      Fuse 7.2 Sprint 37

      Description

      The following error occurs in camel when building in PNC

      [ERROR] Failed to execute goal on project camel-kafka: Could not resolve dependencies for project org.apache.camel:camel-kafka:jar:2.21.0.fuse-720040-redhat-00001: Could not find artifact org.apache.kafka:kafka_2.11:jar:2.0.0.redhat-00003 in indy-mvn (http://indy.project-newcastle.svc.cluster.local/api/folo/track/build_camel-2-21-0-7-2-0_20181031.1255/maven/group/build_camel-2-21-0-7-2-0_20181031.1255) -> [Help 1]
      
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal on project camel-kafka: Could not resolve dependencies for project org.apache.camel:camel-kafka:jar:2.21.0.fuse-720040-redhat-00001: Could not find artifact org.apache.kafka:kafka_2.11:jar:2.0.0.redhat-00003 in indy-mvn (http://indy.project-newcastle.svc.cluster.local/api/folo/track/build_camel-2-21-0-7-2-0_20181031.1255/maven/group/build_camel-2-21-0-7-2-0_20181031.1255)
      

      This is due to the following automatic alignment in PNC in parent/pom.xml -

       +    <kafka-version>2.0.0.redhat-00003</kafka-version>
       -    <kafka-version>2.0.0</kafka-version>
      

      The aligned productised build does not produce the required org.apache.kafka:kafka_2.11:jar:2.0.0.redhat-00003 artifact, the build is from PNC and can be found here http://orch.cloud.pnc.engineering.redhat.com/pnc-web/#/projects/86/build-configs/365/build-records/7308 as part of AMQ streams, It is a gradle project that has been converted to a maven project, this is normally a complex and fiddly process.

      The productised build currently only targets scala 2.12, the upstream version targets both 2.12 and 2.11

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  oscerd Andrea Cosentino
                  Reporter:
                  jonnychristison Jonathan Christison
                  Tester:
                  Viliam Kasala
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: