Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-9141

karaf2-cxf-rest - NoSuchMethodError: BeanConfig.setUsePathBasedConfig(Z)V

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: FIS 2.0
    • Fix Version/s: FIS 2.0-patches
    • Component/s: FIS-Quickstarts
    • Labels:
      None
    • Epic Link:
    • Steps to Reproduce:
      1. Clone karaf2-cxf-rest-1.0.0.fuse-000075
      2. mvn clean install && mvn fabric8:deploy

      Description

      Error

      2018-07-02 08:46:38,281 | ERROR | FelixStartLevel  | BlueprintContainerImpl           | 14 - org.apache.aries.blueprint.core - 1.8.0 | Unable to start blueprint container for bundle io.fabric8.quickstarts.karaf2-cxf-rest/1.0.0.fuse-000075
      org.osgi.service.blueprint.container.ComponentDefinitionException: Unable to initialize bean customerService
      	at org.apache.aries.blueprint.container.BeanRecipe.runBeanProcInit(BeanRecipe.java:738)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BeanRecipe.internalCreate2(BeanRecipe.java:848)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BeanRecipe.internalCreate(BeanRecipe.java:811)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.di.AbstractRecipe$1.call(AbstractRecipe.java:79)[14:org.apache.aries.blueprint.core:1.8.0]
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266)[:1.8.0_171]
      	at org.apache.aries.blueprint.di.AbstractRecipe.create(AbstractRecipe.java:88)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintRepository.createInstances(BlueprintRepository.java:255)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintRepository.createAll(BlueprintRepository.java:186)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintContainerImpl.instantiateEagerComponents(BlueprintContainerImpl.java:725)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintContainerImpl.doRun(BlueprintContainerImpl.java:412)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintContainerImpl.run(BlueprintContainerImpl.java:277)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:300)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:269)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintExtender.createContainer(BlueprintExtender.java:265)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.blueprint.container.BlueprintExtender.modifiedBundle(BlueprintExtender.java:255)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:500)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.customizerModified(BundleHookBundleTracker.java:433)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$AbstractTracked.track(BundleHookBundleTracker.java:725)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$Tracked.bundleChanged(BundleHookBundleTracker.java:463)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.aries.util.tracker.hook.BundleHookBundleTracker$BundleEventHook.event(BundleHookBundleTracker.java:422)[14:org.apache.aries.blueprint.core:1.8.0]
      	at org.apache.felix.framework.util.SecureAction.invokeBundleEventHook(SecureAction.java:1127)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.util.EventDispatcher.createWhitelistFromHooks(EventDispatcher.java:696)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.util.EventDispatcher.fireBundleEvent(EventDispatcher.java:484)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.Felix.fireBundleEvent(Felix.java:4429)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.Felix.startBundle(Felix.java:2100)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1299)[org.apache.felix.framework-4.4.1.jar:]
      	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:304)[org.apache.felix.framework-4.4.1.jar:]
      	at java.lang.Thread.run(Thread.java:748)[:1.8.0_171]
      Caused by: java.lang.NoSuchMethodError: io.swagger.jaxrs.config.BeanConfig.setUsePathBasedConfig(Z)V
      	at org.apache.cxf.jaxrs.swagger.Swagger2Feature.addSwaggerResource(Swagger2Feature.java:145)
      	at org.apache.cxf.jaxrs.swagger.AbstractSwaggerFeature.initialize(AbstractSwaggerFeature.java:69)
      	at org.apache.cxf.jaxrs.JAXRSServerFactoryBean.applyFeatures(JAXRSServerFactoryBean.java:252)
      	at org.apache.cxf.jaxrs.JAXRSServerFactoryBean.create(JAXRSServerFactoryBean.java:196)
      	at org.apache.cxf.jaxrs.JAXRSServerFactoryBean.init(JAXRSServerFactoryBean.java:142)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[:1.8.0_171]
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)[:1.8.0_171]
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)[:1.8.0_171]
      	at java.lang.reflect.Method.invoke(Method.java:498)[:1.8.0_171]
      	at org.apache.aries.blueprint.utils.ReflectionUtils.invoke(ReflectionUtils.java:299)
      	at org.apache.aries.blueprint.container.BeanRecipe.invoke(BeanRecipe.java:980)
      	at org.apache.aries.blueprint.container.BeanRecipe.runBeanProcInit(BeanRecipe.java:736)
      	... 27 more
      

      It looks like wrong version of swagger-jaxrs (and others swagger-*) - 1.5.4 vs 1.5.10, because 1.5.4-version-of-swagger-jaxrs doesn't contain setUsePathBasedConfig method.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                tcunning Thomas Cunningham
                Reporter:
                llowinge Lukáš Löwinger
                Tester:
                Jan Kasztura
              • Votes:
                0 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: