Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: fuse-7.0
    • Fix Version/s: fuse-7.1
    • Component/s: Karaf
    • Labels:
    • Steps to Reproduce:
      • take fresh Fuse 7.0 standalone
      • start Karaf
      • run features:install connector
    • Workaround Description:
      Hide
      karaf@root()>install mvn:org.apache.geronimo.components/geronimo-transaction/3.1.4
      Bundle ID: 223
      karaf@root()> features:install connector
      karaf@root()> start 223
      
      Show
      karaf@root()>install mvn:org.apache.geronimo.components/geronimo-transaction/3.1.4 Bundle ID: 223 karaf@root()> features:install connector karaf@root()> start 223

      Description

      Taking a new Fuse 7.0 Standalone Karaf container and running
      feature:install connector raises

      2018-05-23 16:57:07,734 | ERROR | l console user karaf | o.a.k.s.s.ShellUtil              | 143 - org.apache.karaf.shell.core - 4.2.0.fuse-000237-redhat-1 | Exception caught while executing command
      org.osgi.service.resolver.ResolutionException: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=connector; type=karaf.feature; version="[3.1.1,3.1.1]"; filter:="(&(osgi.identity=connector)(type=karaf.feature)(version>=3.1.1)(version<=3.1.1))" [caused by: Unable to resolve connector/3.1.1: missing requirement [connector/3.1.1] osgi.identity; osgi.identity=org.apache.geronimo.components.geronimo-connector; type=osgi.bundle; version="[3.1.1,3.1.1]"; resolution:=mandatory [caused by: Unable to resolve org.apache.geronimo.components.geronimo-connector/3.1.1: missing requirement [org.apache.geronimo.components.geronimo-connector/3.1.1] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.geronimo.transaction.manager)(version>=3.0.0)(!(version>=4.0.0)))"]]
      	at org.apache.felix.resolver.ResolutionError.toException(ResolutionError.java:42) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.doResolve(ResolverImpl.java:391) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:377) ~[?:?]
      	at org.apache.felix.resolver.ResolverImpl.resolve(ResolverImpl.java:331) ~[?:?]
      	at org.apache.karaf.features.internal.region.SubsystemResolver.resolve(SubsystemResolver.java:248) ~[?:?]
      	at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:388) ~[?:?]
      	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1025) ~[?:?]
      	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(FeaturesServiceImpl.java:964) ~[?:?]
      	at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:?]
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) ~[?:?]
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) ~[?:?]
      	at java.lang.Thread.run(Thread.java:748) [?:?]
      

      The same error raised on the Karaf console.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  grgrzybek Grzegorz Grzybek
                  Reporter:
                  mielket Torsten Mielke
                  Tester:
                  Andrej Vano
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: