Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-5951

Shell SCR bundle redeploy loop with camel-amq quickstart

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: jboss-fuse-6.3
    • Component/s: None
    • Labels:
      None
    • Sprint:
      Sprint 7 - towards CR2

      Description

      Separate from ENTESB-5860 issue in camel-amq quickstart we can get into an infinite redpeloy loop with shell SCR bundle. Full log here:

      https://gist.githubusercontent.com/janstey/a2ff73137de589a64fb4f383581f4716/raw/e5c99ae9c2206c5dbad7356171d88530e34f4f27/gistfile1.txt

      You'll see this over an over again:

      2016-08-05 11:01:57,086 | INFO  | loyer-3-thread-1 | Deployer                         | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 | Scheduled stop for bundle:org.apache.karaf.shell.scr with a timeout limit of 60 seconds
      2016-08-05 11:01:57,087 | INFO  | loyer-3-thread-1 | ActivateCommandComponent         | 93 - org.apache.karaf.shell.scr - 2.4.0.redhat-630157 | Deactivating the Apache Karaf SCR Activate Command
      2016-08-05 11:01:57,088 | INFO  | loyer-3-thread-1 | DeactivateCommandComponent       | 93 - org.apache.karaf.shell.scr - 2.4.0.redhat-630157 | Deactivating the Apache Karaf SCR Deactivate Command
      2016-08-05 11:01:57,089 | INFO  | loyer-3-thread-1 | DetailsCommandComponent          | 93 - org.apache.karaf.shell.scr - 2.4.0.redhat-630157 | Deactivating the Apache Karaf SCR Details Command
      2016-08-05 11:01:57,089 | INFO  | loyer-3-thread-1 | ListCommandComponent             | 93 - org.apache.karaf.shell.scr - 2.4.0.redhat-630157 | Deactivating the Apache Karaf SCR List Command
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 | Refreshing bundles:
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     io.fabric8.fabric-agent / 1.2.0.redhat-630157 (Wired to io.fabric8.fabric-core/1.2.0.redhat-630157 which is being refreshed)
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     io.fabric8.fabric-core / 1.2.0.redhat-630157 (Wired to org.apache.karaf.admin.management/2.4.0.redhat-630157 which is being refreshed)
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     io.fabric8.fabric-git / 1.2.0.redhat-630157 (Wired to io.fabric8.fabric-core/1.2.0.redhat-630157 which is being refreshed)
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     io.fabric8.fabric-git-server / 1.2.0.redhat-630157 (Wired to io.fabric8.fabric-git/1.2.0.redhat-630157 which is being refreshed)
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     io.fabric8.fabric-web / 1.2.0.redhat-630157 (Wired to io.fabric8.fabric-core/1.2.0.redhat-630157 which is being refreshed)
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     io.fabric8.patch.patch-core / 1.2.0.redhat-630157 (Wired to io.fabric8.fabric-git/1.2.0.redhat-630157 which is being refreshed)
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     io.fabric8.runtime.fabric-runtime-container-karaf-registration / 1.2.0.redhat-630157 (Wired to io.fabric8.fabric-core/1.2.0.redhat-630157 which is being refreshed)
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     org.apache.karaf.admin.core / 2.4.0.redhat-630157 (Should be wired to: jline/2.12.1.redhat-002 (through [org.apache.karaf.admin.core/2.4.0.redhat-630157] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.fusesource.jansi)(version>=1.11.0)(!(version>=2.0.0)))"))
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     org.apache.karaf.admin.management / 2.4.0.redhat-630157 (Wired to org.apache.karaf.admin.core/2.4.0.redhat-630157 which is being refreshed)
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     org.apache.karaf.shell.osgi / 2.4.0.redhat-630157 (Should be wired to: jline/2.12.1.redhat-002 (through [org.apache.karaf.shell.osgi/2.4.0.redhat-630157] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.fusesource.jansi)(version>=1.11.0)(!(version>=2.0.0)))"))
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     org.apache.karaf.shell.scr / 2.4.0.redhat-630157 (Should be wired to: jline/2.12.1.redhat-002 (through [org.apache.karaf.shell.scr/2.4.0.redhat-630157] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.fusesource.jansi)(version>=1.11.0)(!(version>=2.0.0)))"))
      2016-08-05 11:01:57,090 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |     org.apache.karaf.shell.ssh / 2.4.0.redhat-630157 (Should be wired to: jline/2.12.1.redhat-002 (through [org.apache.karaf.shell.ssh/2.4.0.redhat-630157] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.fusesource.jansi)(version>=1.11.0)(!(version>=2.0.0)))"))
      2016-08-05 11:01:57,134 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 | Starting bundles:
      2016-08-05 11:01:57,135 | INFO  | 6.0.1-1-thread-1 | Agent                            | 86 - io.fabric8.fabric-agent - 1.2.0.redhat-630157 |   org.apache.karaf.shell.scr / 2.4.0.redhat-630157
      

      Problem happens with jline dependency is used in the quickstart pom which is then picked up by fabric8 maven plugin. Of course, this is a core shell bundle and not needed by the quickstart.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                janstey Jonathan Anstey
                Reporter:
                janstey Jonathan Anstey
                Tester:
                Jan Kasztura
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: