Details

    • Sprint:
      Sprint 5 - towards ER2

      Description

      Misleading description

      JBossFuse:karaf@root> features:info camel-jetty8
      Description of camel-jetty8 2.17.0.redhat-630069 feature
      ----------------------------------------------------------------
      camel-jetty8 intend to work with jetty8, so this feature only works in the karaf container which support jetty8, e.g. karaf 2.x/3.x
      ----------------------------------------------------------------
      Feature has no configuration
      Feature has no configuration files
      Feature depends on:
        jetty 0.0.0
        camel-core 2.17.0.redhat-630069
      Feature contains followed bundles:
       mvn:org.apache.camel/camel-http-common/2.17.0.redhat-630069 start-level=50
       mvn:org.apache.camel/camel-jetty-common/2.17.0.redhat-630069 start-level=50
       mvn:org.apache.camel/camel-jetty8/2.17.0.redhat-630069 start-level=50
      Feature has no conditionals.
      
      JBossFuse:karaf@root> features:info camel-jetty9
      Description of camel-jetty9 2.17.0.redhat-630069 feature
      ----------------------------------------------------------------
      camel-jetty9 intend to work with jetty9, so this feature only works in the karaf container which support jetty9, e.g. karaf 4.x
      ----------------------------------------------------------------
      Feature has no configuration
      Feature has no configuration files
      Feature depends on:
        jetty 0.0.0
        camel-core 2.17.0.redhat-630069
      Feature contains followed bundles:
       mvn:org.apache.camel/camel-http-common/2.17.0.redhat-630069 start-level=50
       mvn:org.apache.camel/camel-jetty-common/2.17.0.redhat-630069 start-level=50
       mvn:org.apache.camel/camel-jetty9/2.17.0.redhat-630069 start-level=50
      Feature has no conditionals.
      

      camel-jetty8 doesn't work in fuse 6.3

      JBossFuse:karaf@root> features:install camel-jetty9
      JBossFuse:karaf@root> features:install camel-jetty8
      Error executing command: Can not resolve feature:
      Unsatisfied requirement(s):
      ---------------------------
         package:(&(package=org.eclipse.jetty.util.ssl)(version>=8.0.0)(!(version>=9.0.0)))
            camel-jetty8
         package:(&(package=org.eclipse.jetty.server)(version>=8.0.0)(!(version>=9.0.0)))
            camel-jetty8
         package:(&(package=org.eclipse.jetty.util.thread)(version>=8.0.0)(!(version>=9.0.0)))
            camel-jetty8
         package:(&(package=org.eclipse.jetty.io)(version>=8.0.0)(!(version>=9.0.0)))
            camel-jetty8
         package:(&(package=org.eclipse.jetty.client)(version>=8.0.0)(!(version>=9.0.0)))
            camel-jetty8
         package:(&(package=org.eclipse.jetty.util)(version>=8.0.0)(!(version>=9.0.0)))
            camel-jetty8
         package:(&(package=org.eclipse.jetty.http)(version>=8.0.0)(!(version>=9.0.0)))
            camel-jetty8
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                oscerd Andrea Cosentino
                Reporter:
                jludvice Josef Ludvicek
                Tester:
                Josef Ludvicek
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: