Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-5509

jms failing on osgi.wiring.package=javax.jms)(version>=1.1.0)(!(version>=2.0.0)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: jboss-fuse-6.3
    • Fix Version/s: jboss-fuse-6.3
    • Component/s: Karaf
    • Labels:
      None
    • Sprint:
      Sprint 5 - towards ER2

      Description

      found in fuse 6.3 build 71

      JBossFuse:karaf@root> features:install jms
      Error executing command: Could not start bundle mvn:org.apache.karaf.jms/org.apache.karaf.jms.core/2.4.0.redhat-630071 in feature(s) jms-2.4.0.redhat-630071: Unresolved constraint in bundle org.apache.karaf.jms.core [295]: Unable to resolve 295.0: missing requirement [295.0] osgi.wiring.package; (&(osgi.wiring.package=javax.jms)(version>=1.1.0)(!(version>=2.0.0)))
      
      JBossFuse:karaf@root> exports | grep jms
          80 org.apache.cxf.binding.soap.jms.interceptor; version=3.1.5
         198 javax.jms; version=2.0.0                
         219 org.apache.activemq.jms.pool; version=5.11.0.redhat-630071
         219 org.apache.activemq.network.jms; version=5.11.0.redhat-630071
         242 org.springframework.jms.listener; version=3.2.16.RELEASE
         242 org.springframework.jms.config; version=3.2.16.RELEASE
         242 org.springframework.jms; version=3.2.16.RELEASE
         242 org.springframework.jms.support.destination; version=3.2.16.RELEASE
         242 org.springframework.jms.support.converter; version=3.2.16.RELEASE
         242 org.springframework.jms.core.support; version=3.2.16.RELEASE
         242 org.springframework.jms.listener.endpoint; version=3.2.16.RELEASE
         242 org.springframework.jms.connection; version=3.2.16.RELEASE
         242 org.springframework.jms.support; version=3.2.16.RELEASE
         242 org.springframework.jms.listener.adapter; version=3.2.16.RELEASE
         242 org.springframework.jms.remoting; version=3.2.16.RELEASE
         242 org.springframework.jms.core; version=3.2.16.RELEASE
         243 org.apache.camel.component.jms; version=2.17.0.redhat-630071
         243 org.apache.camel.component.jms.reply; version=2.17.0.redhat-630071
      JBossFuse:karaf@root> la | grep 198
      [ 198] [Active     ] [            ] [       ] [   80] Apache Geronimo JMS Spec 2.0 (1.0.0.alpha-2)
      JBossFuse:karaf@root> la | grep 199
      [ 199] [Active     ] [            ] [       ] [   80] geronimo-jms_1.1_spec (1.1.1)
      JBossFuse:karaf@root> exports | grep 199
         199 No active exported packages. This command only works on started bundles, use osgi:headers instead
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                grgrzybek Grzegorz Grzybek
                Reporter:
                jludvice Josef Ludvicek
                Tester:
                Josef Ludvicek
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: