Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-4921 problem with installing / uninstalling features in fuse 6.3
  3. ENTESB-4953

incorrect version imports in features:install camel-spring-security

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: jboss-fuse-6.3
    • Fix Version/s: jboss-fuse-6.3
    • Component/s: Camel, Karaf
    • Labels:
      None

      Description

      Fuse provides spring 3.2.12.RELEASE
      but camel-spring-security requires 3.2.13.RELEASE

      JBossFuse:karaf@root> exports | grep org.springframework.core.io
         192 org.springframework.core.io; version=3.2.12.RELEASE
         192 org.springframework.core.io.support; version=3.2.12.RELEASE
      
      JBossFuse:karaf@root> features:install camel-spring-security
      Error executing command: Can not resolve feature:
      Unsatisfied requirement(s):                                                                                                                                                                                          
      ---------------------------                                                                                                                                                                                          
         package:(&(package=org.springframework.security.access)(version>=3.0.0)(!(version>=4.0.0)))                                                                                                                       
            camel-spring-security                                                                                                                                                                                          
         package:(&(package=org.springframework.core.io)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))                                                                                                                      
            Spring Security Core                                                                                                                                                                                           
         package:(&(package=org.springframework.context.event)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))                                                                                                                
            Spring Security Core                                                                                                                                                                                           
         package:(&(package=org.springframework.beans.propertyeditors)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))                                                                                                        
            Spring Security Core                                                                                                                                                                                           
         package:(&(package=org.springframework.core)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))                                                                                                                         
            Spring Security Core                                                                                                                                                                                           
         package:(&(package=org.springframework.security.access.event)(version>=3.0.0)(!(version>=4.0.0)))
            camel-spring-security
         package:(&(package=org.springframework.security.core.context)(version>=3.0.0)(!(version>=4.0.0)))
            camel-spring-security
         package:(&(package=org.springframework.util)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
            Spring Security Core
         package:(&(package=org.springframework.security.core)(version>=3.0.0)(!(version>=4.0.0)))
            camel-spring-security
         package:(&(package=org.springframework.context.expression)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
            Spring Security Core
         package:(&(package=org.springframework.context)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
            Spring Security Core
         package:(&(package=org.springframework.context.support)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
            Spring Security Core
         package:(&(package=org.springframework.core.annotation)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
            Spring Security Core
         package:(&(package=org.springframework.core.task)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
            Spring Security Core
         package:(&(package=org.springframework.security.authentication)(version>=3.0.0)(!(version>=4.0.0)))
            camel-spring-security
         package:(&(package=org.springframework.beans.factory)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
            Spring Security Core
         package:(&(package=org.springframework.beans)(version>=3.2.13.RELEASE)(!(version>=5.0.0)))
            Spring Security Core
      

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                oscerd Andrea Cosentino
                Reporter:
                jludvice Josef Ludvicek
                Tester:
                Josef Ludvicek
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: