Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-4166

ActiveMQ - Browse: Checkboxes at message rows works badly after messages list is manually refreshed

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: jboss-fuse-6.2.1
    • Fix Version/s: jboss-fuse-6.3
    • Component/s: Hawtio
    • Labels:
    • Environment:

      fuse 6.2.1 047
      windows 2008: IE 10 (Chrome on the same machine works fine)
      windows 2012: IE11, Chrome 45 (Firefox on the same machine works fine)

      Description

      1. Send at least 2 messages to a selected queue.
      2. open Browse subtab
      3. click refresh button (not the browser's one, use the one at the page)
      4. click the checkboxes at the left side of the message rows.

      Usually but not always happens that checking only 1 row checkes also "select all" checkbox and similar issues. It can be seen on attached screencast.

      Note:
      Side effect of wrong checking is wrong enabling/disabling Resend, Move and Delete buttons.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  kearls Kevin Earls
                  Reporter:
                  mastepan Martin Stepanek
                  Tester:
                  Martin Stepanek
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: