Uploaded image for project: 'Red Hat Fuse'
  1. Red Hat Fuse
  2. ENTESB-10289

Camel-linkedin quickstart rely on jetty and terefore on servlet-api < 4.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: fuse-7.3
    • Component/s: Camel
    • Labels:
      None

      Description

      Recent update of fuse-karaf to undertow 2/servlet 4 showed, that camel-linkedin component relies on Jetty (e.g. on org.eclipse.jetty.util)

      This is not correct. Component should be refactored to not need jetty (and servlet-api < 4.0)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  jondruse Jiri Ondrusek
                  Reporter:
                  jondruse Jiri Ondrusek
                  Tester:
                  Jan Kasztura
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: