Embedded Jopr
  1. Embedded Jopr
  2. EMBJOPR-366

Updating farmed EAR/WAR fails and un-farms app with error @Out attribute requires non-null value: updateBackingContentAction.packageType

    Details

    • Type: Bug Bug
    • Status: Closed Closed (View Workflow)
    • Priority: Blocker Blocker
    • Resolution: Done
    • Affects Version/s: 1.3.4.SP5
    • Fix Version/s: 1.3.4.SP6
    • Component/s: Plugin
    • Labels:
      None
    • Environment:
      JBoss EAP 5.1.0 admin-console (1.3.4 SP1)
    • Steps to Reproduce:

      #. Install EAP 5.1.0
      #. Enable admin/admin jmx-console account for all profile
      #. Start EAP 5.1 using all profile
      #. Go to admin-console (http://localhost:8080/admin-console)
      #. Login using admin/admin
      #. Expand and select localhost.localdomain/JBossAS Server/JBoss EAP (all)/Applications/Web Application (WAR)s
      #. Click 'Add a new resource' button
      #. Click 'Browse' button and browse to a sample WAR (war-servlet-calculator.war)
      #. Set the following 'Deployment Options'
      Deploy Exploded?: No
      Deploy Farmed: Yes
      #. Click 'Continue' button
      WAR should deploy successfully
      #. Expand and select localhost.localdomain/JBossAS Server/JBoss EAP (all)/Applications/Web Application (WAR)s/war-servlet-calculator.war
      #. Click 'Content' tab
      #. Click 'Browse' button and browse to a sample WAR (war-servlet-calculator.war)
      #. Click 'Update' button

      Show
      #. Install EAP 5.1.0 #. Enable admin/admin jmx-console account for all profile #. Start EAP 5.1 using all profile #. Go to admin-console ( http://localhost:8080/admin-console ) #. Login using admin/admin #. Expand and select localhost.localdomain/JBossAS Server/JBoss EAP (all)/Applications/Web Application (WAR)s #. Click 'Add a new resource' button #. Click 'Browse' button and browse to a sample WAR (war-servlet-calculator.war) #. Set the following 'Deployment Options' Deploy Exploded?: No Deploy Farmed: Yes #. Click 'Continue' button WAR should deploy successfully #. Expand and select localhost.localdomain/JBossAS Server/JBoss EAP (all)/Applications/Web Application (WAR)s/war-servlet-calculator.war #. Click 'Content' tab #. Click 'Browse' button and browse to a sample WAR (war-servlet-calculator.war) #. Click 'Update' button
    • Bugzilla Update:
      Perform
    • Similar Issues:
      Show 10 results 

      Description

      When attempting to update a deployed application (EAR/WAR) which has been deployed in the farm directory, the original application is removed from farm and the new version is deployed to the deploy directory and the following exception is being displayed in the UI:

      javax.el.ELException: org.jboss.seam.RequiredException: @Out attribute requires non-null value: updateBackingContentAction.packageType
      at org.jboss.el.util.ReflectionUtil.invokeMethod(ReflectionUtil.java:339)
      at org.jboss.el.util.ReflectionUtil.invokeMethod(ReflectionUtil.java:280)
      at org.jboss.el.parser.AstMethodSuffix.getValue(AstMethodSuffix.java:59)
      at org.jboss.el.parser.AstMethodSuffix.invoke(AstMethodSuffix.java:65)
      at org.jboss.el.parser.AstValue.invoke(AstValue.java:96)
      at org.jboss.el.MethodExpressionImpl.invoke(MethodExpressionImpl.java:276)
      at org.jboss.seam.core.Expressions$2.invoke(Expressions.java:175)
      at org.jboss.seam.navigation.Page.preRender(Page.java:311)
      at org.jboss.seam.navigation.Pages.preRender(Pages.java:351)
      at org.jboss.seam.jsf.SeamPhaseListener.preRenderPage(SeamPhaseListener.java:561)
      at org.jboss.seam.jsf.SeamPhaseListener.beforeRenderResponse(SeamPhaseListener.java:472)
      at org.jboss.seam.jsf.SeamPhaseListener.beforeServletPhase(SeamPhaseListener.java:148)
      at org.jboss.seam.jsf.SeamPhaseListener.beforePhase(SeamPhaseListener.java:118)
      at com.sun.faces.lifecycle.Phase.handleBeforePhase(Phase.java:214)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:96)
      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:139)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:266)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:83)
      at org.jboss.seam.web.IdentityFilter.doFilter(IdentityFilter.java:40)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.web.MultipartFilter.doFilter(MultipartFilter.java:86)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.web.ExceptionFilter.doFilter(ExceptionFilter.java:64)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.web.RedirectFilter.doFilter(RedirectFilter.java:45)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.ajax4jsf.webapp.BaseXMLFilter.doXmlFilter(BaseXMLFilter.java:178)
      at org.ajax4jsf.webapp.BaseFilter.handleRequest(BaseFilter.java:295)
      at org.ajax4jsf.webapp.BaseFilter.processUploadsAndHandleRequest(BaseFilter.java:373)
      at org.ajax4jsf.webapp.BaseFilter.doFilter(BaseFilter.java:500)
      at org.jboss.seam.web.Ajax4jsfFilter.doFilter(Ajax4jsfFilter.java:56)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.web.LoggingFilter.doFilter(LoggingFilter.java:60)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.servlet.SeamFilter.doFilter(SeamFilter.java:158)
      at org.jboss.on.embedded.LazyStartupFilter.doFilter(LazyStartupFilter.java:87)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:183)
      at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:95)
      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:451)
      at java.lang.Thread.run(Thread.java:636)
      Caused by:org.jboss.seam.RequiredException: @Out attribute requires non-null value: updateBackingContentAction.packageType
      at org.jboss.seam.Component.outjectAttribute(Component.java:1767)
      at org.jboss.seam.Component.outjectAttributes(Component.java:1758)
      at org.jboss.seam.Component.outject(Component.java:1611)
      at org.jboss.seam.core.BijectionInterceptor.aroundInvoke(BijectionInterceptor.java:86)
      at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:68)
      at org.jboss.seam.core.ConversationInterceptor.aroundInvoke(ConversationInterceptor.java:56)
      at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:68)
      at org.jboss.seam.core.MethodContextInterceptor.aroundInvoke(MethodContextInterceptor.java:44)
      at org.jboss.seam.intercept.SeamInvocationContext.proceed(SeamInvocationContext.java:68)
      at org.jboss.seam.intercept.RootInterceptor.invoke(RootInterceptor.java:107)
      at org.jboss.seam.intercept.JavaBeanInterceptor.interceptInvocation(JavaBeanInterceptor.java:185)
      at org.jboss.seam.intercept.JavaBeanInterceptor.invoke(JavaBeanInterceptor.java:103)
      at org.jboss.on.embedded.ui.content.UpdateBackingContentAction_$$javassist_seam_16.init(UpdateBackingContentAction$$_javassist_seam_16.java)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      at java.lang.reflect.Method.invoke(Method.java:616)
      at org.jboss.el.util.ReflectionUtil.invokeMethod(ReflectionUtil.java:335)
      at org.jboss.el.util.ReflectionUtil.invokeMethod(ReflectionUtil.java:280)
      at org.jboss.el.parser.AstMethodSuffix.getValue(AstMethodSuffix.java:59)
      at org.jboss.el.parser.AstMethodSuffix.invoke(AstMethodSuffix.java:65)
      at org.jboss.el.parser.AstValue.invoke(AstValue.java:96)
      at org.jboss.el.MethodExpressionImpl.invoke(MethodExpressionImpl.java:276)
      at org.jboss.seam.core.Expressions$2.invoke(Expressions.java:175)
      at org.jboss.seam.navigation.Page.preRender(Page.java:311)
      at org.jboss.seam.navigation.Pages.preRender(Pages.java:351)
      at org.jboss.seam.jsf.SeamPhaseListener.preRenderPage(SeamPhaseListener.java:561)
      at org.jboss.seam.jsf.SeamPhaseListener.beforeRenderResponse(SeamPhaseListener.java:472)
      at org.jboss.seam.jsf.SeamPhaseListener.beforeServletPhase(SeamPhaseListener.java:148)
      at org.jboss.seam.jsf.SeamPhaseListener.beforePhase(SeamPhaseListener.java:118)
      at com.sun.faces.lifecycle.Phase.handleBeforePhase(Phase.java:214)
      at com.sun.faces.lifecycle.Phase.doPhase(Phase.java:96)
      at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:139)
      at javax.faces.webapp.FacesServlet.service(FacesServlet.java:266)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:83)
      at org.jboss.seam.web.IdentityFilter.doFilter(IdentityFilter.java:40)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.web.MultipartFilter.doFilter(MultipartFilter.java:86)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.web.ExceptionFilter.doFilter(ExceptionFilter.java:64)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.web.RedirectFilter.doFilter(RedirectFilter.java:45)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.ajax4jsf.webapp.BaseXMLFilter.doXmlFilter(BaseXMLFilter.java:178)
      at org.ajax4jsf.webapp.BaseFilter.handleRequest(BaseFilter.java:295)
      at org.ajax4jsf.webapp.BaseFilter.processUploadsAndHandleRequest(BaseFilter.java:373)
      at org.ajax4jsf.webapp.BaseFilter.doFilter(BaseFilter.java:500)
      at org.jboss.seam.web.Ajax4jsfFilter.doFilter(Ajax4jsfFilter.java:56)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.web.LoggingFilter.doFilter(LoggingFilter.java:60)
      at org.jboss.seam.servlet.SeamFilter$FilterChainImpl.doFilter(SeamFilter.java:69)
      at org.jboss.seam.servlet.SeamFilter.doFilter(SeamFilter.java:158)
      at org.jboss.on.embedded.LazyStartupFilter.doFilter(LazyStartupFilter.java:87)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:235)
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
      at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:183)
      at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:95)
      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.process(SecurityContextEstablishmentValve.java:126)
      at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:70)
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
      at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158)
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:330)
      at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:829)
      at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:598)
      at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:451)
      at java.lang.Thread.run(Thread.java:636)

      The result is the application is un-deployed or removed from all nodes of the cluster and the new version is only being deployed to the single node. Additionally, the error displayed to the user is unexpected.

        Issue Links

          Activity

          RH Bugzilla Integration
          added a comment -

          Charles Crouch <ccrouch@redhat.com> made a comment on bug 646631

          (4:21:56 PM) ccrouch: ips: how come you set the Target Release of https://bugzilla.redhat.com/show_bug.cgi?id=646631 to be RHQ4.3?
          (4:22:19 PM) ccrouch: i think it should be 4.5, given stefan_n's commits https://bugzilla.redhat.com/show_bug.cgi?id=646631#c19
          (4:24:40 PM) ips: yeah, you're right, i misread the date on his commits
          (4:25:05 PM) ccrouch: ok, i'll reset it

          Show
          RH Bugzilla Integration
          added a comment - Charles Crouch <ccrouch@redhat.com> made a comment on bug 646631 (4:21:56 PM) ccrouch: ips: how come you set the Target Release of https://bugzilla.redhat.com/show_bug.cgi?id=646631 to be RHQ4.3? (4:22:19 PM) ccrouch: i think it should be 4.5, given stefan_n's commits https://bugzilla.redhat.com/show_bug.cgi?id=646631#c19 (4:24:40 PM) ips: yeah, you're right, i misread the date on his commits (4:25:05 PM) ccrouch: ok, i'll reset it
          Ian Springer
          added a comment -

          I tried cherry-picking the three commits for bug 646631 to the AdminConsole_EAP_5_1 branch. Mazz's commit merged cleanly, but Stefan's two commits had a lot of conflicts, due to so much time passing since AdminConsole_EAP_5_1 was forked. To fix this, we'll either need to manually fix all those conflicts or upgrade the version of RHQ used by the AdminConsole_EAP_5_1 EmbJopr branch to 4.4 or 4.5.

          Show
          Ian Springer
          added a comment - I tried cherry-picking the three commits for bug 646631 to the AdminConsole_EAP_5_1 branch. Mazz's commit merged cleanly, but Stefan's two commits had a lot of conflicts, due to so much time passing since AdminConsole_EAP_5_1 was forked. To fix this, we'll either need to manually fix all those conflicts or upgrade the version of RHQ used by the AdminConsole_EAP_5_1 EmbJopr branch to 4.4 or 4.5.
          Stefan Negrea
          added a comment -

          Cherry-picked the two commits to AdminConsole_EAP_5_1. I only merged changes relevant to farmed deployments.

          AdminConsole_EAP_5_1 branch commits:
          http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commit;h=8a9c9cbdb14665c4a98dc2c74275a91fe4a9cf0b
          http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commit;h=83656e08b3fec3ffbc877e2603641af59ff24d7f

          Show
          Stefan Negrea
          added a comment - Cherry-picked the two commits to AdminConsole_EAP_5_1. I only merged changes relevant to farmed deployments. AdminConsole_EAP_5_1 branch commits: http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commit;h=8a9c9cbdb14665c4a98dc2c74275a91fe4a9cf0b http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commit;h=83656e08b3fec3ffbc877e2603641af59ff24d7f
          Show
          Larry O'Leary
          added a comment - Committed to release branch for 1.3.4.SP6 as per https://issues.jboss.org/browse/EMBJOPR-366?focusedCommentId=12703452&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-12703452
          RH Bugzilla Integration
          added a comment -

          Heiko W. Rupp <hrupp@redhat.com> changed the Status of bug 646631 from VERIFIED to CLOSED

          Show
          RH Bugzilla Integration
          added a comment - Heiko W. Rupp <hrupp@redhat.com> changed the Status of bug 646631 from VERIFIED to CLOSED

            People

            • Assignee:
              Stefan Negrea
              Reporter:
              Larry O'Leary
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: