Embedded Jopr
  1. Embedded Jopr
  2. EMBJOPR-274

PluginTransformException < FileNotFoundException: /localhost/admin-console/plugins/jopr-hibernate-plugin-1.4.0-SNAPSHOT.jar

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 1.3.3
    • Fix Version/s: 1.4.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      EAP 5.0 GA
      RHQ and Jopr 1.4.0-SNAPSHOT commit 6a59e0f19febd2d316872a2d1af27e14d0d65247
    • Similar Issues:
      Show 3 results 

      Description

      All plugins report failure when being loaded - see bellow and the attached log. However, the admin console seems to work correctly.

      00:01:34,468 ERROR [PluginManager] Plugin [Hibernate] at [jndi:/localhost/admin-console/plugins/jopr-hibernate-plugin-1.4.0-SNAPSHOT.jar] could not be loaded and will therefore not be deployed.
      org.rhq.core.clientapi.descriptor.PluginTransformException: Failed to create plugin.
      at org.rhq.core.clientapi.descriptor.PluginTransformer.toPlugin(PluginTransformer.java:77)
      at org.rhq.core.pc.plugin.PluginManager$1.execute(PluginManager.java:197)
      at org.rhq.core.pc.plugin.PluginManager.loadPlugin(PluginManager.java:361)
      at org.rhq.core.pc.plugin.PluginManager.initialize(PluginManager.java:152)
      at org.rhq.core.pc.PluginContainer.startContainerService(PluginContainer.java:365)
      at org.rhq.core.pc.PluginContainer.initialize(PluginContainer.java:241)
      at org.jboss.on.embedded.ui.BootstrapAction.initPluginContainer(BootstrapAction.java:155)
      [...]
      Caused by: java.io.FileNotFoundException: /localhost/admin-console/plugins/jopr-hibernate-plugin-1.4.0-SNAPSHOT.jar (No such file or directory)
      at java.io.FileInputStream.open(Native Method)
      at java.io.FileInputStream.<init>(FileInputStream.java:106)
      at org.rhq.core.util.MessageDigestGenerator.getDigest(MessageDigestGenerator.java:207)
      at org.rhq.core.util.MessageDigestGenerator.getDigestString(MessageDigestGenerator.java:226)
      at org.rhq.core.clientapi.descriptor.PluginTransformer.getMd5(PluginTransformer.java:98)
      at org.rhq.core.clientapi.descriptor.PluginTransformer.toPlugin(PluginTransformer.java:71)
      ... 96 more

      1. plugins-load.log
        47 kB
        Ondrej Zizka
      2. plugins-load-full.log
        58 kB
        Ondrej Zizka

        Activity

        Ian Springer
        added a comment -

        This was a bug in the RHQ code that loads plugin jars. That code was assuming the plugin jar URLS were file URLs, but when running inside the admin-console, they were jndi URLs. This is now fixed in the RHQ git 'gwt' branch - rev 927194d360d4b47023fa9713d18365081457a1f6 - it still needs to be merged into the 'master' branch.

        Show
        Ian Springer
        added a comment - This was a bug in the RHQ code that loads plugin jars. That code was assuming the plugin jar URLS were file URLs, but when running inside the admin-console, they were jndi URLs. This is now fixed in the RHQ git 'gwt' branch - rev 927194d360d4b47023fa9713d18365081457a1f6 - it still needs to be merged into the 'master' branch.
        Ian Springer
        added a comment -

        Cherry picked into master branch - rev 804620f.

        Show
        Ian Springer
        added a comment - Cherry picked into master branch - rev 804620f.
        Ian Springer
        added a comment -

        This was fixed in RHQ 3.0.0.B06, to which EmbJopr was upgraded in r940.

        Show
        Ian Springer
        added a comment - This was fixed in RHQ 3.0.0.B06, to which EmbJopr was upgraded in r940.

          People

          • Assignee:
            Ian Springer
            Reporter:
            Ondrej Zizka
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: