Uploaded image for project: 'Fuse Tools'
  1. Fuse Tools
  2. FUSETOOLS-772

IDE launch configuration not starting ESB in debug mode

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Rejected
    • Affects Version/s: 2.1.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      OSX ESB 7.0.0.fuse-061

      Description

      Setting the KARAF_DEBUG environment variable does not open the default debug port (5005) . To reproduce:
      *Register a FuseESBEnterprise-7.0.0 as a server in IDE 2.1.
      *Double click to get the server Overview
      *Open launch configuration
      *Click on the Environment tab
      *Add variable KARAF_DEBUG value true
      *Append environment to native environment
      *Click OK
      *Right click on the server and Start

      I would expect to see the following as per setting "export KARAF_DEBUG=true" on the command line:
      karaf: Enabling Java debug options: -Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=5005
      Listening for transport dt_socket at address: 5005
      Please wait while Fuse ESB is loading...

      Port 5005 is closed to telnet

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  lhein Lars Heinemann
                  Reporter:
                  jkorab1 Jakub Korab
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: