Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-721

NPE in getting fabric container version

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Todays RCP
    • Similar Issues:
      Show 9 results 

      Description

      I noticed this in the error log

      java.lang.reflect.InvocationTargetException
      	at sun.reflect.GeneratedMethodAccessor107.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89)
      	at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175)
      	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32)
      	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21)
      	at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36)
      	at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152)
      	at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399)
      	at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485)
      	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
      	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
      	at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:752)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636)
      	at org.eclipse.jface.viewers.AbstractTableViewer$2.run(AbstractTableViewer.java:592)
      	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443)
      	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404)
      	at org.eclipse.jface.viewers.AbstractTableViewer.inputChanged(AbstractTableViewer.java:590)
      	at org.eclipse.jface.viewers.ContentViewer.setInput(ContentViewer.java:280)
      	at org.eclipse.jface.viewers.StructuredViewer.setInput(StructuredViewer.java:1690)
      	at com.fusesource.rider.commons.Viewers.setInput(Viewers.java:99)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView.setInput(PropertySourceTableView.java:84)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView.setPropertySources(PropertySourceTableView.java:70)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableSheetPage.setPropertySources(PropertySourceTableSheetPage.java:52)
      	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage.setPropertySources(ContainerTableSheetPage.java:150)
      	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage.updateData(ContainerTableSheetPage.java:440)
      	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:222)
      	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
      	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
      	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
      	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
      	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
      	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
      	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
      	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
      	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
      	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
      	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
      	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
      Caused by: java.lang.RuntimeException: java.lang.NullPointerException
      	at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:172)
      	at com.fusesource.ide.fabric.navigator.ContainerViewBean.version(ContainerViewBean.java:53)
      	at com.fusesource.ide.fabric.navigator.ContainerViewBean.getVersion(ContainerViewBean.java:49)
      	... 56 more
      Caused by: java.lang.NullPointerException
      	at org.fusesource.fabric.api.VersionSequence.<init>(VersionSequence.java:26)
      	at org.fusesource.fabric.internal.VersionImpl.<init>(VersionImpl.java:33)
      	at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:170)
      	... 58 more
      Root exception:
      java.lang.RuntimeException: java.lang.NullPointerException
      	at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:172)
      	at com.fusesource.ide.fabric.navigator.ContainerViewBean.version(ContainerViewBean.java:53)
      	at com.fusesource.ide.fabric.navigator.ContainerViewBean.getVersion(ContainerViewBean.java:49)
      	at sun.reflect.GeneratedMethodAccessor107.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89)
      	at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175)
      	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32)
      	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21)
      	at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36)
      	at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152)
      	at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399)
      	at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485)
      	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
      	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
      	at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:752)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636)
      	at org.eclipse.jface.viewers.AbstractTableViewer$2.run(AbstractTableViewer.java:592)
      	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443)
      	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404)
      	at org.eclipse.jface.viewers.AbstractTableViewer.inputChanged(AbstractTableViewer.java:590)
      	at org.eclipse.jface.viewers.ContentViewer.setInput(ContentViewer.java:280)
      	at org.eclipse.jface.viewers.StructuredViewer.setInput(StructuredViewer.java:1690)
      	at com.fusesource.rider.commons.Viewers.setInput(Viewers.java:99)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView.setInput(PropertySourceTableView.java:84)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView.setPropertySources(PropertySourceTableView.java:70)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableSheetPage.setPropertySources(PropertySourceTableSheetPage.java:52)
      	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage.setPropertySources(ContainerTableSheetPage.java:150)
      	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage.updateData(ContainerTableSheetPage.java:440)
      	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:222)
      	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
      	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
      	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
      	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
      	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
      	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
      	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
      	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
      	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
      	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
      	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
      	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
      Caused by: java.lang.NullPointerException
      	at org.fusesource.fabric.api.VersionSequence.<init>(VersionSequence.java:26)
      	at org.fusesource.fabric.internal.VersionImpl.<init>(VersionImpl.java:33)
      	at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:170)
      	... 58 more
      

      It may be related to that previous reported issue with the error when destroying my mq fabric container

        Activity

        Claus Ibsen
        added a comment -

        Yeah it seems related. I just tried to destroy the root container as well. And I got the following 2 errors in the error log

        java.lang.reflect.InvocationTargetException
        	at sun.reflect.GeneratedMethodAccessor102.invoke(Unknown Source)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89)
        	at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56)
        	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175)
        	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32)
        	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21)
        	at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36)
        	at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152)
        	at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399)
        	at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485)
        	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
        	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
        	at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:711)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636)
        	at org.eclipse.jface.viewers.StructuredViewer$7.run(StructuredViewer.java:1508)
        	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443)
        	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404)
        	at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1506)
        	at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:537)
        	at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1465)
        	at com.fusesource.rider.commons.Viewers.refresh(Viewers.java:40)
        	at com.fusesource.rider.commons.ui.views.ColumnViewSupport.refresh(ColumnViewSupport.java:90)
        	at com.fusesource.rider.commons.tree.Refreshables.refresh(Refreshables.java:11)
        	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:223)
        	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
        	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
        	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
        	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
        	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
        	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
        	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
        	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
        	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
        	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
        	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
        	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
        	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
        Caused by: java.lang.RuntimeException: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /fabric/configs/containers/mq
        	at org.fusesource.fabric.internal.ContainerImpl.getProfiles(ContainerImpl.java:208)
        	at com.fusesource.ide.fabric.navigator.ContainerViewBean.getProfiles(ContainerViewBean.java:88)
        	at com.fusesource.ide.fabric.navigator.ContainerViewBean.getProfileIds(ContainerViewBean.java:74)
        	... 53 more
        Caused by: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /fabric/configs/containers/mq
        	at org.apache.zookeeper.KeeperException.create(KeeperException.java:111)
        	at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
        	at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1131)
        	at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1160)
        	at org.linkedin.zookeeper.client.ZooKeeperImpl.getData(ZooKeeperImpl.java:178)
        	at org.linkedin.zookeeper.client.AbstractZooKeeper.getData(AbstractZooKeeper.java:200)
        	at org.linkedin.zookeeper.client.AbstractZKClient.getStringData(AbstractZKClient.java:136)
        	at org.fusesource.fabric.internal.ContainerImpl.getProfiles(ContainerImpl.java:196)
        	... 55 more
        Root exception:
        java.lang.RuntimeException: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /fabric/configs/containers/mq
        	at org.fusesource.fabric.internal.ContainerImpl.getProfiles(ContainerImpl.java:208)
        	at com.fusesource.ide.fabric.navigator.ContainerViewBean.getProfiles(ContainerViewBean.java:88)
        	at com.fusesource.ide.fabric.navigator.ContainerViewBean.getProfileIds(ContainerViewBean.java:74)
        	at sun.reflect.GeneratedMethodAccessor102.invoke(Unknown Source)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89)
        	at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56)
        	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175)
        	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32)
        	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21)
        	at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36)
        	at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152)
        	at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399)
        	at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485)
        	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
        	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
        	at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:711)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636)
        	at org.eclipse.jface.viewers.StructuredViewer$7.run(StructuredViewer.java:1508)
        	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443)
        	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404)
        	at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1506)
        	at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:537)
        	at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1465)
        	at com.fusesource.rider.commons.Viewers.refresh(Viewers.java:40)
        	at com.fusesource.rider.commons.ui.views.ColumnViewSupport.refresh(ColumnViewSupport.java:90)
        	at com.fusesource.rider.commons.tree.Refreshables.refresh(Refreshables.java:11)
        	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:223)
        	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
        	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
        	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
        	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
        	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
        	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
        	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
        	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
        	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
        	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
        	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
        	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
        	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
        Caused by: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /fabric/configs/containers/mq
        	at org.apache.zookeeper.KeeperException.create(KeeperException.java:111)
        	at org.apache.zookeeper.KeeperException.create(KeeperException.java:51)
        	at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1131)
        	at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1160)
        	at org.linkedin.zookeeper.client.ZooKeeperImpl.getData(ZooKeeperImpl.java:178)
        	at org.linkedin.zookeeper.client.AbstractZooKeeper.getData(AbstractZooKeeper.java:200)
        	at org.linkedin.zookeeper.client.AbstractZKClient.getStringData(AbstractZKClient.java:136)
        	at org.fusesource.fabric.internal.ContainerImpl.getProfiles(ContainerImpl.java:196)
        	... 55 more
        

        And the 2nd is

        java.lang.reflect.InvocationTargetException
        	at sun.reflect.GeneratedMethodAccessor107.invoke(Unknown Source)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89)
        	at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56)
        	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175)
        	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32)
        	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21)
        	at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36)
        	at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152)
        	at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399)
        	at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485)
        	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
        	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
        	at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:711)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636)
        	at org.eclipse.jface.viewers.StructuredViewer$7.run(StructuredViewer.java:1508)
        	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443)
        	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404)
        	at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1506)
        	at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:537)
        	at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1465)
        	at com.fusesource.rider.commons.Viewers.refresh(Viewers.java:40)
        	at com.fusesource.rider.commons.ui.views.ColumnViewSupport.refresh(ColumnViewSupport.java:90)
        	at com.fusesource.rider.commons.tree.Refreshables.refresh(Refreshables.java:11)
        	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:223)
        	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
        	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
        	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
        	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
        	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
        	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
        	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
        	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
        	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
        	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
        	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
        	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
        	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
        Caused by: java.lang.RuntimeException: java.lang.NullPointerException
        	at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:172)
        	at com.fusesource.ide.fabric.navigator.ContainerViewBean.version(ContainerViewBean.java:53)
        	at com.fusesource.ide.fabric.navigator.ContainerViewBean.getVersion(ContainerViewBean.java:49)
        	... 53 more
        Caused by: java.lang.NullPointerException
        	at org.fusesource.fabric.api.VersionSequence.<init>(VersionSequence.java:26)
        	at org.fusesource.fabric.internal.VersionImpl.<init>(VersionImpl.java:33)
        	at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:170)
        	... 55 more
        Root exception:
        java.lang.RuntimeException: java.lang.NullPointerException
        	at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:172)
        	at com.fusesource.ide.fabric.navigator.ContainerViewBean.version(ContainerViewBean.java:53)
        	at com.fusesource.ide.fabric.navigator.ContainerViewBean.getVersion(ContainerViewBean.java:49)
        	at sun.reflect.GeneratedMethodAccessor107.invoke(Unknown Source)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89)
        	at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56)
        	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175)
        	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32)
        	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21)
        	at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36)
        	at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152)
        	at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399)
        	at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485)
        	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
        	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
        	at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:711)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649)
        	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636)
        	at org.eclipse.jface.viewers.StructuredViewer$7.run(StructuredViewer.java:1508)
        	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443)
        	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404)
        	at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1506)
        	at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:537)
        	at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1465)
        	at com.fusesource.rider.commons.Viewers.refresh(Viewers.java:40)
        	at com.fusesource.rider.commons.ui.views.ColumnViewSupport.refresh(ColumnViewSupport.java:90)
        	at com.fusesource.rider.commons.tree.Refreshables.refresh(Refreshables.java:11)
        	at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:223)
        	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
        	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
        	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
        	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
        	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
        	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
        	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
        	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
        	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
        	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
        	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
        	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
        	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
        Caused by: java.lang.NullPointerException
        	at org.fusesource.fabric.api.VersionSequence.<init>(VersionSequence.java:26)
        	at org.fusesource.fabric.internal.VersionImpl.<init>(VersionImpl.java:33)
        	at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:170)
        	... 55 more
        
        Show
        Claus Ibsen
        added a comment - Yeah it seems related. I just tried to destroy the root container as well. And I got the following 2 errors in the error log java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor102.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89) at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56) at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175) at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32) at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21) at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36) at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152) at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399) at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49) at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175) at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:711) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636) at org.eclipse.jface.viewers.StructuredViewer$7.run(StructuredViewer.java:1508) at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443) at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404) at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1506) at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:537) at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1465) at com.fusesource.rider.commons.Viewers.refresh(Viewers.java:40) at com.fusesource.rider.commons.ui.views.ColumnViewSupport.refresh(ColumnViewSupport.java:90) at com.fusesource.rider.commons.tree.Refreshables.refresh(Refreshables.java:11) at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:223) at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35) at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135) at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938) at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615) at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701) at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665) at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499) at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577) at org.eclipse.equinox.launcher.Main.run(Main.java:1410) Caused by: java.lang.RuntimeException: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /fabric/configs/containers/mq at org.fusesource.fabric.internal.ContainerImpl.getProfiles(ContainerImpl.java:208) at com.fusesource.ide.fabric.navigator.ContainerViewBean.getProfiles(ContainerViewBean.java:88) at com.fusesource.ide.fabric.navigator.ContainerViewBean.getProfileIds(ContainerViewBean.java:74) ... 53 more Caused by: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /fabric/configs/containers/mq at org.apache.zookeeper.KeeperException.create(KeeperException.java:111) at org.apache.zookeeper.KeeperException.create(KeeperException.java:51) at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1131) at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1160) at org.linkedin.zookeeper.client.ZooKeeperImpl.getData(ZooKeeperImpl.java:178) at org.linkedin.zookeeper.client.AbstractZooKeeper.getData(AbstractZooKeeper.java:200) at org.linkedin.zookeeper.client.AbstractZKClient.getStringData(AbstractZKClient.java:136) at org.fusesource.fabric.internal.ContainerImpl.getProfiles(ContainerImpl.java:196) ... 55 more Root exception: java.lang.RuntimeException: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /fabric/configs/containers/mq at org.fusesource.fabric.internal.ContainerImpl.getProfiles(ContainerImpl.java:208) at com.fusesource.ide.fabric.navigator.ContainerViewBean.getProfiles(ContainerViewBean.java:88) at com.fusesource.ide.fabric.navigator.ContainerViewBean.getProfileIds(ContainerViewBean.java:74) at sun.reflect.GeneratedMethodAccessor102.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89) at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56) at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175) at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32) at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21) at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36) at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152) at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399) at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49) at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175) at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:711) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636) at org.eclipse.jface.viewers.StructuredViewer$7.run(StructuredViewer.java:1508) at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443) at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404) at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1506) at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:537) at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1465) at com.fusesource.rider.commons.Viewers.refresh(Viewers.java:40) at com.fusesource.rider.commons.ui.views.ColumnViewSupport.refresh(ColumnViewSupport.java:90) at com.fusesource.rider.commons.tree.Refreshables.refresh(Refreshables.java:11) at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:223) at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35) at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135) at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938) at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615) at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701) at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665) at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499) at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577) at org.eclipse.equinox.launcher.Main.run(Main.java:1410) Caused by: org.apache.zookeeper.KeeperException$NoNodeException: KeeperErrorCode = NoNode for /fabric/configs/containers/mq at org.apache.zookeeper.KeeperException.create(KeeperException.java:111) at org.apache.zookeeper.KeeperException.create(KeeperException.java:51) at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1131) at org.apache.zookeeper.ZooKeeper.getData(ZooKeeper.java:1160) at org.linkedin.zookeeper.client.ZooKeeperImpl.getData(ZooKeeperImpl.java:178) at org.linkedin.zookeeper.client.AbstractZooKeeper.getData(AbstractZooKeeper.java:200) at org.linkedin.zookeeper.client.AbstractZKClient.getStringData(AbstractZKClient.java:136) at org.fusesource.fabric.internal.ContainerImpl.getProfiles(ContainerImpl.java:196) ... 55 more And the 2nd is java.lang.reflect.InvocationTargetException at sun.reflect.GeneratedMethodAccessor107.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89) at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56) at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175) at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32) at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21) at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36) at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152) at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399) at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49) at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175) at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:711) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636) at org.eclipse.jface.viewers.StructuredViewer$7.run(StructuredViewer.java:1508) at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443) at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404) at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1506) at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:537) at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1465) at com.fusesource.rider.commons.Viewers.refresh(Viewers.java:40) at com.fusesource.rider.commons.ui.views.ColumnViewSupport.refresh(ColumnViewSupport.java:90) at com.fusesource.rider.commons.tree.Refreshables.refresh(Refreshables.java:11) at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:223) at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35) at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135) at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938) at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615) at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701) at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665) at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499) at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577) at org.eclipse.equinox.launcher.Main.run(Main.java:1410) Caused by: java.lang.RuntimeException: java.lang.NullPointerException at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:172) at com.fusesource.ide.fabric.navigator.ContainerViewBean.version(ContainerViewBean.java:53) at com.fusesource.ide.fabric.navigator.ContainerViewBean.getVersion(ContainerViewBean.java:49) ... 53 more Caused by: java.lang.NullPointerException at org.fusesource.fabric.api.VersionSequence.<init>(VersionSequence.java:26) at org.fusesource.fabric.internal.VersionImpl.<init>(VersionImpl.java:33) at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:170) ... 55 more Root exception: java.lang.RuntimeException: java.lang.NullPointerException at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:172) at com.fusesource.ide.fabric.navigator.ContainerViewBean.version(ContainerViewBean.java:53) at com.fusesource.ide.fabric.navigator.ContainerViewBean.getVersion(ContainerViewBean.java:49) at sun.reflect.GeneratedMethodAccessor107.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89) at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56) at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:175) at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32) at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21) at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36) at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152) at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399) at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49) at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175) at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:711) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649) at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636) at org.eclipse.jface.viewers.StructuredViewer$7.run(StructuredViewer.java:1508) at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443) at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404) at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1506) at org.eclipse.jface.viewers.ColumnViewer.refresh(ColumnViewer.java:537) at org.eclipse.jface.viewers.StructuredViewer.refresh(StructuredViewer.java:1465) at com.fusesource.rider.commons.Viewers.refresh(Viewers.java:40) at com.fusesource.rider.commons.ui.views.ColumnViewSupport.refresh(ColumnViewSupport.java:90) at com.fusesource.rider.commons.tree.Refreshables.refresh(Refreshables.java:11) at com.fusesource.ide.fabric.navigator.ContainerTableSheetPage$10.run(ContainerTableSheetPage.java:223) at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35) at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135) at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938) at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615) at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701) at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665) at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499) at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577) at org.eclipse.equinox.launcher.Main.run(Main.java:1410) Caused by: java.lang.NullPointerException at org.fusesource.fabric.api.VersionSequence.<init>(VersionSequence.java:26) at org.fusesource.fabric.internal.VersionImpl.<init>(VersionImpl.java:33) at org.fusesource.fabric.internal.ContainerImpl.getVersion(ContainerImpl.java:170) ... 55 more
        James Strachan
        added a comment -

        added a fix to fabric; should appear in beta-055 or GA...

        Show
        James Strachan
        added a comment - added a fix to fabric; should appear in beta-055 or GA...

          People

          • Assignee:
            James Strachan
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: