Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-689

Deploying fuse esb - cbr example using drag n drop over JMX fails with a null in the path

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Similar Issues:
      Show 9 results 

      Description

      So I am trying the new drag n drop of a project to deploy to Fuse ESB.

      I have Fuse ESB7 running, and connected from Fuse IDE over JMX.
      I then import the Fuse ESB7 examples into Fuse IDE, and then drag n drop the cbr example to the Fuse ESB in the JMX tree on the bundles node.

      I can see Fuse IDE builds and tries to install the example

      I find this in the error log

      java.io.IOException: Installation of a bundle with location fab:mvn:org.fusesource.examples/cbr/null failed with the message: Unable to cache bundle: fab:mvn:org.fusesource.examples/cbr/null
      	at org.apache.aries.jmx.framework.Framework.installBundle(Framework.java:83)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:93)
      	at com.sun.jmx.mbeanserver.StandardMBeanIntrospector.invokeM2(StandardMBeanIntrospector.java:27)
      	at com.sun.jmx.mbeanserver.MBeanIntrospector.invokeM(MBeanIntrospector.java:208)
      	at com.sun.jmx.mbeanserver.PerInterface.invoke(PerInterface.java:120)
      	at com.sun.jmx.mbeanserver.MBeanSupport.invoke(MBeanSupport.java:262)
      	at javax.management.StandardMBean.invoke(StandardMBean.java:391)
      	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:836)
      	at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:761)
      	at javax.management.remote.rmi.RMIConnectionImpl.doOperation(RMIConnectionImpl.java:1427)
      	at javax.management.remote.rmi.RMIConnectionImpl.access$200(RMIConnectionImpl.java:72)
      	at javax.management.remote.rmi.RMIConnectionImpl$PrivilegedOperation.run(RMIConnectionImpl.java:1265)
      	at javax.management.remote.rmi.RMIConnectionImpl.doPrivilegedOperation(RMIConnectionImpl.java:1360)
      	at javax.management.remote.rmi.RMIConnectionImpl.invoke(RMIConnectionImpl.java:788)
      	at sun.reflect.GeneratedMethodAccessor40.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:303)
      	at sun.rmi.transport.Transport$1.run(Transport.java:159)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at sun.rmi.transport.Transport.serviceCall(Transport.java:155)
      	at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:535)
      	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:790)
      	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:649)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:680)
      Caused by: org.osgi.framework.BundleException: Unable to cache bundle: fab:mvn:org.fusesource.examples/cbr/null
      	at org.apache.felix.framework.Felix.installBundle(Felix.java:2780)
      	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165)
      	at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:138)
      	at org.apache.aries.jmx.framework.Framework.installBundle(Framework.java:80)
      	... 30 more
      Caused by: java.io.IOException: URL [mvn:org.fusesource.examples/cbr/null] could not be resolved.
      	at org.fusesource.fabric.fab.osgi.internal.FabResolverFactoryImpl$FabResolverImpl.getInfo(FabResolverFactoryImpl.java:244)
      	at org.fusesource.fabric.fab.osgi.internal.FabConnection.getInputStream(FabConnection.java:117)
      	at org.apache.felix.framework.util.SecureAction.getURLConnectionInputStream(SecureAction.java:520)
      	at org.apache.felix.framework.cache.JarRevision.initialize(JarRevision.java:165)
      	at org.apache.felix.framework.cache.JarRevision.<init>(JarRevision.java:77)
      	at org.apache.felix.framework.cache.BundleArchive.createRevisionFromLocation(BundleArchive.java:878)
      	at org.apache.felix.framework.cache.BundleArchive.reviseInternal(BundleArchive.java:550)
      	at org.apache.felix.framework.cache.BundleArchive.<init>(BundleArchive.java:153)
      	at org.apache.felix.framework.cache.BundleCache.create(BundleCache.java:277)
      	at org.apache.felix.framework.Felix.installBundle(Felix.java:2776)
      	... 33 more
      Caused by: java.lang.RuntimeException: URL [mvn:org.fusesource.examples/cbr/null] could not be resolved.
      	at org.ops4j.pax.url.mvn.internal.Connection.getInputStream(Connection.java:195)
      	at java.net.URL.openStream(URL.java:1010)
      	at org.fusesource.fabric.fab.util.Files.urlToFile(Files.java:68)
      	at org.fusesource.fabric.fab.osgi.internal.FabResolverFactoryImpl$FabResolverImpl.getJarFile(FabResolverFactoryImpl.java:202)
      	at org.fusesource.fabric.fab.osgi.internal.FabResolverFactoryImpl$FabResolverImpl.resolvePomDetails(FabResolverFactoryImpl.java:219)
      	at org.fusesource.fabric.fab.osgi.internal.FabResolverFactoryImpl$FabResolverImpl.getVersionedDependencyId(FabResolverFactoryImpl.java:167)
      	at org.fusesource.fabric.fab.osgi.internal.FabClassPathResolver.resolve(FabClassPathResolver.java:113)
      	at org.fusesource.fabric.fab.osgi.internal.FabResolverFactoryImpl$FabResolverImpl.configureInstructions(FabResolverFactoryImpl.java:283)
      	at org.fusesource.fabric.fab.osgi.internal.FabResolverFactoryImpl$FabResolverImpl.createInstructions(FabResolverFactoryImpl.java:275)
      	at org.fusesource.fabric.fab.osgi.internal.FabResolverFactoryImpl$FabResolverImpl.getInfo(FabResolverFactoryImpl.java:229)
      	... 42 more
      

        Activity

        Claus Ibsen
        added a comment -

        Ah I added a version to the pom.xml of the cbr example

        eg i added

             <version>7.0.0.fuse-beta-051</version>
        

        After this

            <groupId>org.fusesource.examples</groupId>
            <artifactId>cbr</artifactId>
            <packaging>jar</packaging>
            <name>Fuse ESB :: Examples :: Content-Based Router</name>
            <description>Content-Based Router Example</description>
        

        The issue could be that the examples do not have an explicit version in their pom.xml but inherit the version from the parent

        Show
        Claus Ibsen
        added a comment - Ah I added a version to the pom.xml of the cbr example eg i added <version>7.0.0.fuse-beta-051</version> After this <groupId>org.fusesource.examples</groupId> <artifactId>cbr</artifactId> <packaging>jar</packaging> <name>Fuse ESB :: Examples :: Content-Based Router</name> <description>Content-Based Router Example</description> The issue could be that the examples do not have an explicit version in their pom.xml but inherit the version from the parent
        James Strachan
        added a comment -

        I wonder if you could retry sometime on a newer version of IDE; we inherit the version now from the parent pom.xml so even if a version isn't specified we should find one

        Show
        James Strachan
        added a comment - I wonder if you could retry sometime on a newer version of IDE; we inherit the version now from the parent pom.xml so even if a version isn't specified we should find one
        Claus Ibsen
        added a comment -

        Yes trying now with beta refresh and latest RCP

        Show
        Claus Ibsen
        added a comment - Yes trying now with beta refresh and latest RCP
        Claus Ibsen
        added a comment -

        Works fine now.

        Show
        Claus Ibsen
        added a comment - Works fine now.

          People

          • Assignee:
            James Strachan
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: