Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-609

Zookeeper still running after local fabric is destroyed

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 7.1.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      IDE 2.1.351 on Windows 2008 64bit
    • Similar Issues:
      Show 8 results 

      Description

      I created a local fabric in the Fabric Explorer in the IDE and started getting these exceptions about every second

      !MESSAGE Unable to open socket to 0:0:0:0:0:0:0:1/0:0:0:0:0:0:0:1:2181
      2012-03-22 12:06:02,199 [main-SendThread(0:0:0:0:0:0:0:1:2181)] WARN org.apache
      .zookeeper.ClientCnxn - Session 0x0 for server null, unexpected error, closing s
      ocket connection and attempting reconnect
      java.net.SocketException: Address family not supported by protocol family: conne
      ct
      at sun.nio.ch.Net.connect(Native Method) ~[na:1.6.0_31]
      at sun.nio.ch.SocketChannelImpl.connect(Unknown Source) ~[na:1.6.0_31]
      at org.apache.zookeeper.ClientCnxnSocketNIO.registerAndConnect(ClientCnx
      nSocketNIO.java:203) ~[na:na]
      at org.apache.zookeeper.ClientCnxnSocketNIO.connect(ClientCnxnSocketNIO.
      java:213) ~[na:na]
      at org.apache.zookeeper.ClientCnxn$SendThread.startConnect(ClientCnxn.ja
      va:952) ~[na:na]
      at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:979) ~
      [na:na]

      Not sure if this is normal, maybe I just need to config something... but when I removed the local fabric in the explorer, I kept getting these exceptions. The only way to stop them was to shutdown the IDE and restart. Maybe some additional shutdown commands need to be issued when deleting a fabric?

        Activity

        Hide
        Lars Heinemann
        added a comment -

        That issue is not to be solved in Fuse IDE. Created a Fabric Issue to further track it.

        Show
        Lars Heinemann
        added a comment - That issue is not to be solved in Fuse IDE. Created a Fabric Issue to further track it.
        Hide
        Lars Heinemann
        added a comment -

        Tried it with the most recent build and it is still the same behaviour.

        Show
        Lars Heinemann
        added a comment - Tried it with the most recent build and it is still the same behaviour.

          People

          • Assignee:
            Lars Heinemann
            Reporter:
            Jonathan Anstey
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: