Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-601

JMX explorer - Does not work with Apache AMQ

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      2.1.355, windows xp
    • Similar Issues:
      Show 10 results 

      Description

      I created a new fuse project, and uses the camel-activemq archetype.

      I start the application by right clicking the camel-context.xml file and run as local process.
      In the JMX explorer I connect to the new maven process, and try to expand the JMX tree.
      It keeps saying "loading..."

      I tried downgrading AMQ to use a vanilla ASF 5.5.1 release.
      Its the same problem.

      This used to work in previous releases of Fuse IDE.

      See screenshot.

      I can see the AMQ mbeans from both jconsole, and as well from Fuse IDE in the properties view in the bottom right corner.

      1. fuseide-thread-dump.txt
        29 kB
        Claus Ibsen
      2. fuseide-thread-dump-camel.txt
        27 kB
        Claus Ibsen
      3. fuseide-thread-dump-camel-amq-disabled.txt
        24 kB
        Claus Ibsen
      1. JMX-AMQ.png
        280 kB

        Activity

        Claus Ibsen
        added a comment -

        This also fails from Fuse Fabric, if you have created a MQ profile container. Then you cannot look in the JMX tree of the fabric explorer on the MQ container.

        Show
        Claus Ibsen
        added a comment - This also fails from Fuse Fabric, if you have created a MQ profile container. Then you cannot look in the JMX tree of the fabric explorer on the MQ container.
        Claus Ibsen
        added a comment -

        A thread dump from Fuse IDE on Mac OSX, while it was hanging in the JMX tree just like on the screenshot.

        Thread dump captured using jvisualvm

        Show
        Claus Ibsen
        added a comment - A thread dump from Fuse IDE on Mac OSX, while it was hanging in the JMX tree just like on the screenshot. Thread dump captured using jvisualvm
        Claus Ibsen
        added a comment -

        And the -camel.txt is the thread dump from the Camel application with embedded AMQ that hangs.

        Show
        Claus Ibsen
        added a comment - And the -camel.txt is the thread dump from the Camel application with embedded AMQ that hangs.
        Claus Ibsen
        added a comment -

        -amq-disabled.txt is a thread dump of the Camel and AMQ embedded app where AMQ has useJmx=false, and this is now working in Fuse IDE, as the JMX Explorer now works.

        Show
        Claus Ibsen
        added a comment - -amq-disabled.txt is a thread dump of the Camel and AMQ embedded app where AMQ has useJmx=false, and this is now working in Fuse IDE, as the JMX Explorer now works.
        James Strachan
        added a comment -

        FWIW when using the latest archetype (2.9.x) it seems to work fine for me here

        Show
        James Strachan
        added a comment - FWIW when using the latest archetype (2.9.x) it seems to work fine for me here
        Lars Heinemann
        added a comment -

        The issue is caused by some dependency issue with FMC.

        Show
        Lars Heinemann
        added a comment - The issue is caused by some dependency issue with FMC.
        Lars Heinemann
        added a comment -

        Should be fixed now with James latest patch.

        Show
        Lars Heinemann
        added a comment - Should be fixed now with James latest patch.

          People

          • Assignee:
            Lars Heinemann
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: