Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-599

Starting Fuse IDE on 32bit Windows by the EXE file shows a console windows in the background

    Details

    • Type: Enhancement Enhancement
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Duplicate Issue
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Similar Issues:
      Show 8 results 

      Description

      See the screenshot

      I started the RCP 32bit windows of Fuse IDE by double clicking the .exe file from the windows explorer.
      This starts a window with a DOS prompt that prints the system out logs.
      And then another windows with the real Fuse IDE.

      I think the RCP of Eclipse has this fixed so there is no extra window in the background with the system out logging.
      We should look into how we can improved this so Fuse IDE on windows looks better when getting started using it.

        Issue Links

          Activity

          Claus Ibsen
          added a comment -

          Ah okat got it.

          In the FuseIDE.ini file it comes as

          -consoleLog
          --launcher.XXMaxPermSize
          256m
          -vmargs
          -Xmx1024M
          -XX:MaxPermSize=256m
          -Dfuse.ide.devmode=TRUE
          

          Changing that file to the follows, removes that extra console windows

          --launcher.XXMaxPermSize
          256m
          -vmargs
          -Xmx1024M
          -XX:MaxPermSize=256m
          -Dfuse.ide.devmode=FALSE
          
          Show
          Claus Ibsen
          added a comment - Ah okat got it. In the FuseIDE.ini file it comes as -consoleLog --launcher.XXMaxPermSize 256m -vmargs -Xmx1024M -XX:MaxPermSize=256m -Dfuse.ide.devmode=TRUE Changing that file to the follows, removes that extra console windows --launcher.XXMaxPermSize 256m -vmargs -Xmx1024M -XX:MaxPermSize=256m -Dfuse.ide.devmode=FALSE
          Lars Heinemann
          added a comment -

          duplicate of ECLIPSE-598

          Show
          Lars Heinemann
          added a comment - duplicate of ECLIPSE-598

            People

            • Assignee:
              Lars Heinemann
              Reporter:
              Claus Ibsen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: