Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-593

ClassCastException when clicking on the containers in the properties view

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Blocker Blocker
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Similar Issues:
      Show 6 results 

      Description

      I got this exception after running fabric for about 2h. I had started to stop some containers.
      And in the list I click on a container to select in the row.

      And I got an error dialog from Eclipse with some ClassCastException.

      java.lang.ClassCastException: org.eclipse.jface.viewers.TreeViewer cannot be cast to org.eclipse.ui.part.PageBookView$SelectionProvider
      	at org.eclipse.ui.part.PageBookView.postSelectionChanged(PageBookView.java:907)
      	at org.eclipse.ui.part.PageBookView.access$3(PageBookView.java:905)
      	at org.eclipse.ui.part.PageBookView$3.selectionChanged(PageBookView.java:172)
      	at org.eclipse.jface.viewers.StructuredViewer$3.run(StructuredViewer.java:888)
      	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
      	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
      	at org.eclipse.jface.viewers.StructuredViewer.firePostSelectionChanged(StructuredViewer.java:886)
      	at org.eclipse.jface.viewers.StructuredViewer.handlePostSelect(StructuredViewer.java:1226)
      	at org.eclipse.jface.viewers.StructuredViewer$5.widgetSelected(StructuredViewer.java:1251)
      	at org.eclipse.jface.util.OpenStrategy.firePostSelectionEvent(OpenStrategy.java:262)
      	at org.eclipse.jface.util.OpenStrategy.access$5(OpenStrategy.java:256)
      	at org.eclipse.jface.util.OpenStrategy$3.run(OpenStrategy.java:433)
      	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
      	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
      	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
      	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
      	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
      	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
      	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
      	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
      	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
      	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
      	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
      	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
      

        Issue Links

          Activity

          Claus Ibsen
          added a comment -

          I reproduced this again today.

          It started occurring after I got that other exception about not being able to connect to the broker fabric instance.
          Then this list of containers started throwing exception when clicking on any of the rows.

          Show
          Claus Ibsen
          added a comment - I reproduced this again today. It started occurring after I got that other exception about not being able to connect to the broker fabric instance. Then this list of containers started throwing exception when clicking on any of the rows.
          Lars Heinemann
          added a comment -

          I am not able to reproduce this issue. What makes me wonder is that there is no click or dbl click action on the container list inside properties view...so this can't be related really...or at least it shouldn't be.
          Could you provide a more detailed step by step list how to reproduce?

          Show
          Lars Heinemann
          added a comment - I am not able to reproduce this issue. What makes me wonder is that there is no click or dbl click action on the container list inside properties view...so this can't be related really...or at least it shouldn't be. Could you provide a more detailed step by step list how to reproduce?

            People

            • Assignee:
              Claus Ibsen
              Reporter:
              Claus Ibsen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: