Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-591

Camel Timer Endpoint MBean getStates does not work

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Minor Minor
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.1.0
    • Component/s: None
    • Labels:
      None
    • Similar Issues:
      Show 7 results 

      Description

      See this exception

      java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at com.fusesource.rider.commons.ui.propsrc.BeanTypePropertyMetadata.getPropertyValue(BeanTypePropertyMetadata.java:89)
      	at com.fusesource.rider.commons.ui.propsrc.BeanPropertySource.getPropertyValue(BeanPropertySource.java:56)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView$2.apply(PropertySourceTableView.java:172)
      	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.apply(FunctionColumnLabelProvider.java:32)
      	at com.fusesource.rider.commons.ui.label.FunctionColumnLabelProvider.getText(FunctionColumnLabelProvider.java:21)
      	at org.eclipse.jface.viewers.ColumnLabelProvider.update(ColumnLabelProvider.java:36)
      	at org.eclipse.jface.viewers.ViewerColumn.refresh(ViewerColumn.java:152)
      	at org.eclipse.jface.viewers.AbstractTableViewer.doUpdateItem(AbstractTableViewer.java:399)
      	at org.eclipse.jface.viewers.StructuredViewer$UpdateItemSafeRunnable.run(StructuredViewer.java:485)
      	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
      	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
      	at org.eclipse.jface.viewers.StructuredViewer.updateItem(StructuredViewer.java:2167)
      	at org.eclipse.jface.viewers.AbstractTableViewer.createItem(AbstractTableViewer.java:277)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefreshAll(AbstractTableViewer.java:757)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:649)
      	at org.eclipse.jface.viewers.AbstractTableViewer.internalRefresh(AbstractTableViewer.java:636)
      	at org.eclipse.jface.viewers.AbstractTableViewer$2.run(AbstractTableViewer.java:592)
      	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1443)
      	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1404)
      	at org.eclipse.jface.viewers.AbstractTableViewer.inputChanged(AbstractTableViewer.java:590)
      	at org.eclipse.jface.viewers.ContentViewer.setInput(ContentViewer.java:280)
      	at org.eclipse.jface.viewers.StructuredViewer.setInput(StructuredViewer.java:1690)
      	at com.fusesource.rider.commons.ui.propsrc.PropertySourceTableView.configureViewer(PropertySourceTableView.java:199)
      	at com.fusesource.rider.commons.ui.views.TableViewSupport.createViewer(TableViewSupport.java:175)
      	at com.fusesource.rider.commons.ui.views.TableViewSupport.createPartControl(TableViewSupport.java:148)
      	at com.fusesource.rider.commons.ui.views.ViewPropertySheetPage.createControl(ViewPropertySheetPage.java:42)
      	at org.eclipse.ui.views.properties.PropertySheet.doCreatePage(PropertySheet.java:213)
      	at org.eclipse.ui.part.PageBookView.createPage(PageBookView.java:408)
      	at org.eclipse.ui.part.PageBookView.partActivated(PageBookView.java:751)
      	at org.eclipse.ui.views.properties.PropertySheet.partActivated(PropertySheet.java:323)
      	at com.fusesource.ide.jmx.ui.internal.views.navigator.DynamicPropertySheetTracker.changePropertySheet(DynamicPropertySheetTracker.java:70)
      	at com.fusesource.ide.jmx.ui.internal.views.navigator.DynamicPropertySheetTracker.selectionChanged(DynamicPropertySheetTracker.java:56)
      	at com.fusesource.ide.jmx.ui.internal.views.navigator.Navigator$1.selectionChanged(Navigator.java:106)
      	at org.eclipse.jface.viewers.Viewer$2.run(Viewer.java:164)
      	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      	at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:49)
      	at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
      	at org.eclipse.jface.viewers.Viewer.fireSelectionChanged(Viewer.java:162)
      	at org.eclipse.jface.viewers.StructuredViewer.updateSelection(StructuredViewer.java:2188)
      	at org.eclipse.jface.viewers.StructuredViewer.handleSelect(StructuredViewer.java:1211)
      	at org.eclipse.ui.navigator.CommonViewer.handleSelect(CommonViewer.java:478)
      	at org.eclipse.jface.viewers.StructuredViewer$4.widgetSelected(StructuredViewer.java:1241)
      	at org.eclipse.jface.util.OpenStrategy.fireSelectionEvent(OpenStrategy.java:239)
      	at org.eclipse.jface.util.OpenStrategy.access$4(OpenStrategy.java:233)
      	at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:403)
      	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4128)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1457)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1480)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1465)
      	at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1270)
      	at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3974)
      	at org.eclipse.swt.widgets.Display.applicationNextEventMatchingMask(Display.java:4875)
      	at org.eclipse.swt.widgets.Display.applicationProc(Display.java:5226)
      	at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
      	at org.eclipse.swt.widgets.Widget.callSuper(Widget.java:220)
      	at org.eclipse.swt.widgets.Widget.mouseDownSuper(Widget.java:1092)
      	at org.eclipse.swt.widgets.Tree.mouseDownSuper(Tree.java:2052)
      	at org.eclipse.swt.widgets.Widget.mouseDown(Widget.java:1084)
      	at org.eclipse.swt.widgets.Control.mouseDown(Control.java:2528)
      	at org.eclipse.swt.widgets.Tree.mouseDown(Tree.java:2007)
      	at org.eclipse.swt.widgets.Display.windowProc(Display.java:5471)
      	at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
      	at org.eclipse.swt.widgets.Widget.callSuper(Widget.java:220)
      	at org.eclipse.swt.widgets.Widget.windowSendEvent(Widget.java:2095)
      	at org.eclipse.swt.widgets.Shell.windowSendEvent(Shell.java:2253)
      	at org.eclipse.swt.widgets.Display.windowProc(Display.java:5535)
      	at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
      	at org.eclipse.swt.widgets.Display.applicationSendEvent(Display.java:4989)
      	at org.eclipse.swt.widgets.Display.applicationProc(Display.java:5138)
      	at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method)
      	at org.eclipse.swt.internal.cocoa.NSApplication.sendEvent(NSApplication.java:128)
      	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3610)
      	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
      	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
      	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
      	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
      	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
      	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
      	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
      	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
      	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
      Caused by: java.lang.reflect.UndeclaredThrowableException
      	at $Proxy27.getState(Unknown Source)
      	... 98 more
      Caused by: java.lang.reflect.InvocationTargetException
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at com.fusesource.fmc.camel.facade.CamelFacadeSupport$1.invoke(CamelFacadeSupport.java:77)
      	... 99 more
      Caused by: java.lang.reflect.UndeclaredThrowableException
      	at $Proxy26.getState(Unknown Source)
      	... 104 more
      Caused by: javax.management.ReflectionException: Target method not found: org.apache.camel.component.timer.TimerEndpoint.getState
      	at javax.management.modelmbean.RequiredModelMBean.resolveMethod(RequiredModelMBean.java:1009)
      	at javax.management.modelmbean.RequiredModelMBean.invoke(RequiredModelMBean.java:948)
      	at javax.management.modelmbean.RequiredModelMBean.getAttribute(RequiredModelMBean.java:1358)
      	at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getAttribute(DefaultMBeanServerInterceptor.java:666)
      	at com.sun.jmx.mbeanserver.JmxMBeanServer.getAttribute(JmxMBeanServer.java:638)
      	at javax.management.remote.rmi.RMIConnectionImpl.doOperation(RMIConnectionImpl.java:1404)
      	at javax.management.remote.rmi.RMIConnectionImpl.access$200(RMIConnectionImpl.java:72)
      	at javax.management.remote.rmi.RMIConnectionImpl$PrivilegedOperation.run(RMIConnectionImpl.java:1265)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at javax.management.remote.rmi.RMIConnectionImpl.doPrivilegedOperation(RMIConnectionImpl.java:1367)
      	at javax.management.remote.rmi.RMIConnectionImpl.getAttribute(RMIConnectionImpl.java:600)
      	at sun.reflect.GeneratedMethodAccessor59.invoke(Unknown Source)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:303)
      	at sun.rmi.transport.Transport$1.run(Transport.java:159)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at sun.rmi.transport.Transport.serviceCall(Transport.java:155)
      	at sun.rmi.transport.tcp.TCPTransport.handleMessages(TCPTransport.java:535)
      	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(TCPTransport.java:790)
      	at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run(TCPTransport.java:649)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
      	at java.lang.Thread.run(Thread.java:680)
      Caused by: java.lang.NoSuchMethodException: org.apache.camel.component.timer.TimerEndpoint.getState()
      	at java.lang.Class.getMethod(Class.java:1605)
      	at javax.management.modelmbean.RequiredModelMBean.resolveMethod(RequiredModelMBean.java:1004)
      	... 23 more
      

        Activity

        Show
        Claus Ibsen
        added a comment - See https://issues.apache.org/jira/browse/CAMEL-5102
        Claus Ibsen
        added a comment -

        Fixed when updating to next release of Camel 2.9

        Show
        Claus Ibsen
        added a comment - Fixed when updating to next release of Camel 2.9
        Claus Ibsen
        added a comment -

        Confirmed fixed with perfectus build 37

        Show
        Claus Ibsen
        added a comment - Confirmed fixed with perfectus build 37

          People

          • Assignee:
            Claus Ibsen
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: