Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-56

Rider - NPE when switching between design / source view in Rider

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.1
    • Component/s: Camel Editor
    • Labels:
      None
    • Similar Issues:
      Show 10 results 

      Description

      This may be a bit hard to reproduce. But when I switch between source / design view (without changing anything) then I can get a NPE from Eclipse.

      It is as if I put the "cursor" and select an EIP pattern in a route or its because I put the cursor on a attribute in the "properties" panel.
      But try selecting and / or change cursor position in the properties panel.

      The NPE happens only when I click the "Design" tab.

      I am using the updated plugin from today. I just updated the plugin about 30-60 min ago.

      java.lang.NullPointerException
      	at org.eclipse.gef.ui.actions.ActionBarContributor.setActiveEditor(ActionBarContributor.java:156)
      	at org.eclipse.ui.internal.EditorActionBars.partChanged(EditorActionBars.java:343)
      	at org.eclipse.ui.internal.WorkbenchPage$3.run(WorkbenchPage.java:635)
      	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
      	at org.eclipse.core.runtime.Platform.run(Platform.java:888)
      	at org.eclipse.ui.internal.WorkbenchPage.activatePart(WorkbenchPage.java:624)
      	at org.eclipse.ui.internal.WorkbenchPage.setActivePart(WorkbenchPage.java:3533)
      	at org.eclipse.ui.internal.WorkbenchPage.requestActivation(WorkbenchPage.java:3077)
      	at org.eclipse.ui.internal.PartPane.requestActivation(PartPane.java:279)
      	at org.eclipse.ui.internal.EditorPane.requestActivation(EditorPane.java:98)
      	at org.eclipse.ui.internal.PartPane.handleEvent(PartPane.java:237)
      	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:3776)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1367)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1390)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1371)
      	at org.eclipse.swt.widgets.Shell.setActiveControl(Shell.java:1355)
      	at org.eclipse.swt.widgets.Control.sendFocusEvent(Control.java:2972)
      	at org.eclipse.swt.widgets.Canvas.sendFocusEvent(Canvas.java:62)
      	at org.eclipse.swt.widgets.Display.checkFocus(Display.java:618)
      	at org.eclipse.swt.widgets.Shell.makeFirstResponder(Shell.java:1112)
      	at org.eclipse.swt.widgets.Display.windowProc(Display.java:5086)
      	at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
      	at org.eclipse.swt.widgets.Widget.callSuper(Widget.java:220)
      	at org.eclipse.swt.widgets.Widget.windowSendEvent(Widget.java:1943)
      	at org.eclipse.swt.widgets.Shell.windowSendEvent(Shell.java:2025)
      	at org.eclipse.swt.widgets.Display.windowProc(Display.java:5040)
      	at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
      	at org.eclipse.swt.widgets.Display.applicationSendEvent(Display.java:4582)
      	at org.eclipse.swt.widgets.Display.applicationProc(Display.java:4659)
      	at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method)
      	at org.eclipse.swt.internal.cocoa.NSApplication.sendEvent(NSApplication.java:115)
      	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3274)
      	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
      	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
      	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
      	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
      	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
      	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
      	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:619)
      	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:574)
      	at org.eclipse.equinox.launcher.Main.run(Main.java:1407)
      

        Issue Links

          Activity

          Lars Heinemann
          added a comment -

          fixed

          Show
          Lars Heinemann
          added a comment - fixed
          James Strachan
          added a comment -

          Seems this has come back again; have seen it when switching between camel editors between design / XML view

          Show
          James Strachan
          added a comment - Seems this has come back again; have seen it when switching between camel editors between design / XML view
          James Strachan
          added a comment -

          Here's the last stack trace I got...

          !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
          !STACK 0
          java.lang.NullPointerException
          at org.eclipse.gef.ui.actions.ActionBarContributor.setActiveEditor(ActionBarContributor.java:156)
          at org.eclipse.ui.internal.EditorActionBars.partChanged(EditorActionBars.java:343)
          at org.eclipse.ui.internal.WorkbenchPage$3.run(WorkbenchPage.java:635)
          at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
          at org.eclipse.core.runtime.Platform.run(Platform.java:888)
          at org.eclipse.ui.internal.WorkbenchPage.activatePart(WorkbenchPage.java:624)
          at org.eclipse.ui.internal.WorkbenchPage.setActivePart(WorkbenchPage.java:3533)
          at org.eclipse.ui.internal.WorkbenchPage.requestActivation(WorkbenchPage.java:3077)
          at org.eclipse.ui.internal.PartPane.requestActivation(PartPane.java:279)
          at org.eclipse.ui.internal.EditorPane.requestActivation(EditorPane.java:98)
          at org.eclipse.ui.internal.PartPane.setFocus(PartPane.java:325)
          at org.eclipse.ui.internal.EditorPane.setFocus(EditorPane.java:127)
          at org.eclipse.ui.internal.PartStack.presentationSelectionChanged(PartStack.java:844)
          at org.eclipse.ui.internal.PartStack.access$1(PartStack.java:827)
          at org.eclipse.ui.internal.PartStack$1.selectPart(PartStack.java:137)
          at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation$1.handleEvent(TabbedStackPresentation.java:133)
          at org.eclipse.ui.internal.presentations.util.AbstractTabFolder.fireEvent(AbstractTabFolder.java:269)
          at org.eclipse.ui.internal.presentations.util.AbstractTabFolder.fireEvent(AbstractTabFolder.java:278)
          at org.eclipse.ui.internal.presentations.defaultpresentation.DefaultTabFolder.access$1(DefaultTabFolder.java:1)
          at org.eclipse.ui.internal.presentations.defaultpresentation.DefaultTabFolder$2.handleEvent(DefaultTabFolder.java:88)
          at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
          at org.eclipse.swt.widgets.Display.sendEvent(Display.java:3776)
          at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1367)
          at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1390)
          at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1375)
          at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1187)
          at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:2743)
          at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1429)

          Show
          James Strachan
          added a comment - Here's the last stack trace I got... !MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench". !STACK 0 java.lang.NullPointerException at org.eclipse.gef.ui.actions.ActionBarContributor.setActiveEditor(ActionBarContributor.java:156) at org.eclipse.ui.internal.EditorActionBars.partChanged(EditorActionBars.java:343) at org.eclipse.ui.internal.WorkbenchPage$3.run(WorkbenchPage.java:635) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.runtime.Platform.run(Platform.java:888) at org.eclipse.ui.internal.WorkbenchPage.activatePart(WorkbenchPage.java:624) at org.eclipse.ui.internal.WorkbenchPage.setActivePart(WorkbenchPage.java:3533) at org.eclipse.ui.internal.WorkbenchPage.requestActivation(WorkbenchPage.java:3077) at org.eclipse.ui.internal.PartPane.requestActivation(PartPane.java:279) at org.eclipse.ui.internal.EditorPane.requestActivation(EditorPane.java:98) at org.eclipse.ui.internal.PartPane.setFocus(PartPane.java:325) at org.eclipse.ui.internal.EditorPane.setFocus(EditorPane.java:127) at org.eclipse.ui.internal.PartStack.presentationSelectionChanged(PartStack.java:844) at org.eclipse.ui.internal.PartStack.access$1(PartStack.java:827) at org.eclipse.ui.internal.PartStack$1.selectPart(PartStack.java:137) at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation$1.handleEvent(TabbedStackPresentation.java:133) at org.eclipse.ui.internal.presentations.util.AbstractTabFolder.fireEvent(AbstractTabFolder.java:269) at org.eclipse.ui.internal.presentations.util.AbstractTabFolder.fireEvent(AbstractTabFolder.java:278) at org.eclipse.ui.internal.presentations.defaultpresentation.DefaultTabFolder.access$1(DefaultTabFolder.java:1) at org.eclipse.ui.internal.presentations.defaultpresentation.DefaultTabFolder$2.handleEvent(DefaultTabFolder.java:88) at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84) at org.eclipse.swt.widgets.Display.sendEvent(Display.java:3776) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1367) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1390) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1375) at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1187) at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:2743) at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1429)
          James Strachan
          added a comment -

          see this related issue btw http://fusesource.com/issues/browse/ECLIPSE-107 seems to be the same stack trace/issue - maybe just another way to cause the same issue

          Show
          James Strachan
          added a comment - see this related issue btw http://fusesource.com/issues/browse/ECLIPSE-107 seems to be the same stack trace/issue - maybe just another way to cause the same issue
          Lars Heinemann
          added a comment -

          Unable to reproduce that. Keep it open for a while but if it doesn't occur another time then please close it.

          Show
          Lars Heinemann
          added a comment - Unable to reproduce that. Keep it open for a while but if it doesn't occur another time then please close it.
          Lars Heinemann
          added a comment -

          fixed the problem

          Show
          Lars Heinemann
          added a comment - fixed the problem

            People

            • Assignee:
              Lars Heinemann
              Reporter:
              Claus Ibsen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: