Uploaded image for project: 'Fuse Tools'
  1. Fuse Tools
  2. FUSETOOLS-558

NPE is raised when trying to access camel routes using the IDE JMX console for older versions of AMQ/Camel.

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 2.0
    • Fix Version/s: 2.1.0
    • Component/s: JMX
    • Labels:
      None
    • Environment:

      Eclipse Indigo with FuseIDE 2.0.26
      MB 5.4.2-fuse-xx-yy

      Description

      It seems like the IDE integrated JMX console does not know how to handle connections to older version of the Camel routes.

      Trying to access the route when connected to an older version of MB/Camel version like MB 5.4.2 will generate a NPE.

      We should consider be checking that the required methods are available when accessing Camel routes and if they are not then the embedded JMX console should not provide those methods.

      Currently, a NPE is generated but there is no stack trace associated with the error.

      We should consider making sure that all stack traces are included within the details window of the IDE,

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                jastrachan James Strachan
                Reporter:
                ccorsi1 Claudio Corsi
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: