Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-331

Message View (in Properties window) doesn't quite render correctly sometimes

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Critical Critical
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: ActiveMQ
    • Labels:
      None
    • Similar Issues:
      Show 6 results 

      Description

      To reproduce; create the 'camel-activemq' archetype via New > Project> Fuse IDE Project ... > (type "act" in the filter to find it).

      Then run it (select the camel-context.xml and right click -> Run As -> Local Camel Context.

      Browsing the endpoints in JMX Explorer you should see some messages; if not drag & drop some of the src/data/message*.xml files onto some of the camel endpoints then browse them.

      Select an endpoint thats got messages in the Messages View in Fuse perspective - then select a message. Does the Properties UI render correctly?

      Its a little random-ish but a way to make sure the render bug shows its head is;

      • select a message
      • click on another view so it loses focus
      • click on a new message in the Messages View, the Properties View should look a bit borked
      • click on the original message in the Messages View it should now render fine again

        Activity

        Hide
        James Strachan
        added a comment -

        fixed in 2.0.14

        Show
        James Strachan
        added a comment - fixed in 2.0.14

          People

          • Assignee:
            James Strachan
            Reporter:
            James Strachan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: