Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: JMX
    • Labels:
      None
    • Environment:
      1.1.84
    • Similar Issues:
      Show 8 results 

      Description

      I enabled message tracing on the CamelContext.

      I dropped the following file in the src/data folder

      <?xml version="1.0" encoding="UTF-8"?>
      <person user="hiram">
        <firstName>Claus</firstName>
        <lastName>Ibsen</lastName>
        <city>Copenhagen</city>
      </person>
      

      To see this message being traced. But I got this error dialog when clicking in the JMX Explorer tree. (see screenshot)

        Activity

        Claus Ibsen
        added a comment -

        And this stacktrace in the error log in eclipse

        javax.xml.bind.UnmarshalException
         - with linked exception:
        [org.xml.sax.SAXParseException: The processing instruction target matching "[xX][mM][lL]" is not allowed.]
        	at javax.xml.bind.helpers.AbstractUnmarshallerImpl.createUnmarshalException(AbstractUnmarshallerImpl.java:315)
        	at com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallerImpl.createUnmarshalException(UnmarshallerImpl.java:503)
        	at com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal0(UnmarshallerImpl.java:204)
        	at com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal(UnmarshallerImpl.java:173)
        	at javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(AbstractUnmarshallerImpl.java:120)
        	at javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(AbstractUnmarshallerImpl.java:103)
        	at org.fusesource.fon.util.messages.Exchanges.unmarshalNoNamespaceXmlString(Exchanges.java:46)
        	at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.createExchange(CamelContextNode.java:401)
        	at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.getTraceExchanges(CamelContextNode.java:364)
        	at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.getTraceExchanges(CamelContextNode.java:351)
        	at com.fusesource.ide.fabric.camel.navigator.RouteNode.browseExchanges(RouteNode.java:65)
        	at com.fusesource.ide.fabric.views.MessagesView.refresh(MessagesView.java:102)
        	at com.fusesource.ide.fabric.views.MessagesView.setExchangeBrowser(MessagesView.java:191)
        	at com.fusesource.ide.fabric.views.MessagesView$1.selectionChanged(MessagesView.java:90)
        	at org.eclipse.ui.internal.AbstractSelectionService.fireSelection(AbstractSelectionService.java:156)
        	at org.eclipse.ui.internal.AbstractSelectionService.setActivePart(AbstractSelectionService.java:282)
        	at org.eclipse.ui.internal.WWinPartService.updateActivePart(WWinPartService.java:135)
        	at org.eclipse.ui.internal.WWinPartService.access$0(WWinPartService.java:125)
        	at org.eclipse.ui.internal.WWinPartService$WWinListener.partDeactivated(WWinPartService.java:50)
        	at org.eclipse.ui.internal.PartListenerList2$4.run(PartListenerList2.java:115)
        	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        	at org.eclipse.core.runtime.Platform.run(Platform.java:888)
        	at org.eclipse.ui.internal.PartListenerList2.fireEvent(PartListenerList2.java:55)
        	at org.eclipse.ui.internal.PartListenerList2.firePartDeactivated(PartListenerList2.java:113)
        	at org.eclipse.ui.internal.PartService.firePartDeactivated(PartService.java:242)
        	at org.eclipse.ui.internal.PartService.setActivePart(PartService.java:300)
        	at org.eclipse.ui.internal.WorkbenchPagePartList.fireActivePartChanged(WorkbenchPagePartList.java:57)
        	at org.eclipse.ui.internal.PartList.setActivePart(PartList.java:136)
        	at org.eclipse.ui.internal.WorkbenchPage.setActivePart(WorkbenchPage.java:3537)
        	at org.eclipse.ui.internal.WorkbenchPage.requestActivation(WorkbenchPage.java:3077)
        	at org.eclipse.ui.internal.PartPane.requestActivation(PartPane.java:279)
        	at org.eclipse.ui.internal.PartPane.handleEvent(PartPane.java:237)
        	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:3783)
        	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1375)
        	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1398)
        	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1379)
        	at org.eclipse.swt.widgets.Shell.setActiveControl(Shell.java:1355)
        	at org.eclipse.swt.widgets.Control.sendFocusEvent(Control.java:2977)
        	at org.eclipse.swt.widgets.Display.checkFocus(Display.java:621)
        	at org.eclipse.swt.widgets.Shell.makeFirstResponder(Shell.java:1112)
        	at org.eclipse.swt.widgets.Display.windowProc(Display.java:5093)
        	at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
        	at org.eclipse.swt.widgets.Widget.callSuper(Widget.java:220)
        	at org.eclipse.swt.widgets.Widget.windowSendEvent(Widget.java:1959)
        	at org.eclipse.swt.widgets.Shell.windowSendEvent(Shell.java:2025)
        	at org.eclipse.swt.widgets.Display.windowProc(Display.java:5047)
        	at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
        	at org.eclipse.swt.widgets.Display.applicationSendEvent(Display.java:4589)
        	at org.eclipse.swt.widgets.Display.applicationProc(Display.java:4666)
        	at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method)
        	at org.eclipse.swt.internal.cocoa.NSApplication.sendEvent(NSApplication.java:115)
        	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3281)
        	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
        	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
        	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
        	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
        	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
        	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
        	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
        	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        	at java.lang.reflect.Method.invoke(Method.java:597)
        	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
        	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
        	at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
        Caused by: org.xml.sax.SAXParseException: The processing instruction target matching "[xX][mM][lL]" is not allowed.
        	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
        	at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174)
        	at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388)
        	at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1414)
        	at com.sun.org.apache.xerces.internal.impl.XMLScanner.scanPIData(XMLScanner.java:701)
        	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanPIData(XMLDocumentFragmentScannerImpl.java:1020)
        	at com.sun.org.apache.xerces.internal.impl.XMLScanner.scanPI(XMLScanner.java:669)
        	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2964)
        	at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
        	at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:140)
        	at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:511)
        	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:808)
        	at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
        	at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119)
        	at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
        	at org.xml.sax.helpers.XMLFilterImpl.parse(XMLFilterImpl.java:333)
        	at com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal0(UnmarshallerImpl.java:200)
        	... 70 more
        
        Show
        Claus Ibsen
        added a comment - And this stacktrace in the error log in eclipse javax.xml.bind.UnmarshalException - with linked exception: [org.xml.sax.SAXParseException: The processing instruction target matching "[xX][mM][lL]" is not allowed.] at javax.xml.bind.helpers.AbstractUnmarshallerImpl.createUnmarshalException(AbstractUnmarshallerImpl.java:315) at com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallerImpl.createUnmarshalException(UnmarshallerImpl.java:503) at com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal0(UnmarshallerImpl.java:204) at com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal(UnmarshallerImpl.java:173) at javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(AbstractUnmarshallerImpl.java:120) at javax.xml.bind.helpers.AbstractUnmarshallerImpl.unmarshal(AbstractUnmarshallerImpl.java:103) at org.fusesource.fon.util.messages.Exchanges.unmarshalNoNamespaceXmlString(Exchanges.java:46) at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.createExchange(CamelContextNode.java:401) at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.getTraceExchanges(CamelContextNode.java:364) at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.getTraceExchanges(CamelContextNode.java:351) at com.fusesource.ide.fabric.camel.navigator.RouteNode.browseExchanges(RouteNode.java:65) at com.fusesource.ide.fabric.views.MessagesView.refresh(MessagesView.java:102) at com.fusesource.ide.fabric.views.MessagesView.setExchangeBrowser(MessagesView.java:191) at com.fusesource.ide.fabric.views.MessagesView$1.selectionChanged(MessagesView.java:90) at org.eclipse.ui.internal.AbstractSelectionService.fireSelection(AbstractSelectionService.java:156) at org.eclipse.ui.internal.AbstractSelectionService.setActivePart(AbstractSelectionService.java:282) at org.eclipse.ui.internal.WWinPartService.updateActivePart(WWinPartService.java:135) at org.eclipse.ui.internal.WWinPartService.access$0(WWinPartService.java:125) at org.eclipse.ui.internal.WWinPartService$WWinListener.partDeactivated(WWinPartService.java:50) at org.eclipse.ui.internal.PartListenerList2$4.run(PartListenerList2.java:115) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.runtime.Platform.run(Platform.java:888) at org.eclipse.ui.internal.PartListenerList2.fireEvent(PartListenerList2.java:55) at org.eclipse.ui.internal.PartListenerList2.firePartDeactivated(PartListenerList2.java:113) at org.eclipse.ui.internal.PartService.firePartDeactivated(PartService.java:242) at org.eclipse.ui.internal.PartService.setActivePart(PartService.java:300) at org.eclipse.ui.internal.WorkbenchPagePartList.fireActivePartChanged(WorkbenchPagePartList.java:57) at org.eclipse.ui.internal.PartList.setActivePart(PartList.java:136) at org.eclipse.ui.internal.WorkbenchPage.setActivePart(WorkbenchPage.java:3537) at org.eclipse.ui.internal.WorkbenchPage.requestActivation(WorkbenchPage.java:3077) at org.eclipse.ui.internal.PartPane.requestActivation(PartPane.java:279) at org.eclipse.ui.internal.PartPane.handleEvent(PartPane.java:237) at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84) at org.eclipse.swt.widgets.Display.sendEvent(Display.java:3783) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1375) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1398) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1379) at org.eclipse.swt.widgets.Shell.setActiveControl(Shell.java:1355) at org.eclipse.swt.widgets.Control.sendFocusEvent(Control.java:2977) at org.eclipse.swt.widgets.Display.checkFocus(Display.java:621) at org.eclipse.swt.widgets.Shell.makeFirstResponder(Shell.java:1112) at org.eclipse.swt.widgets.Display.windowProc(Display.java:5093) at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method) at org.eclipse.swt.widgets.Widget.callSuper(Widget.java:220) at org.eclipse.swt.widgets.Widget.windowSendEvent(Widget.java:1959) at org.eclipse.swt.widgets.Shell.windowSendEvent(Shell.java:2025) at org.eclipse.swt.widgets.Display.windowProc(Display.java:5047) at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method) at org.eclipse.swt.widgets.Display.applicationSendEvent(Display.java:4589) at org.eclipse.swt.widgets.Display.applicationProc(Display.java:4666) at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method) at org.eclipse.swt.internal.cocoa.NSApplication.sendEvent(NSApplication.java:115) at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3281) at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640) at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604) at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438) at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575) at org.eclipse.equinox.launcher.Main.run(Main.java:1408) Caused by: org.xml.sax.SAXParseException: The processing instruction target matching "[xX][mM][lL]" is not allowed. at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195) at com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174) at com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388) at com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1414) at com.sun.org.apache.xerces.internal.impl.XMLScanner.scanPIData(XMLScanner.java:701) at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanPIData(XMLDocumentFragmentScannerImpl.java:1020) at com.sun.org.apache.xerces.internal.impl.XMLScanner.scanPI(XMLScanner.java:669) at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2964) at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648) at com.sun.org.apache.xerces.internal.impl.XMLNSDocumentScannerImpl.next(XMLNSDocumentScannerImpl.java:140) at com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:511) at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:808) at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737) at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:119) at com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205) at org.xml.sax.helpers.XMLFilterImpl.parse(XMLFilterImpl.java:333) at com.sun.xml.internal.bind.v2.runtime.unmarshaller.UnmarshallerImpl.unmarshal0(UnmarshallerImpl.java:200) ... 70 more
        James Strachan
        added a comment -

        I think this is now fixed in 2.0.4 - could you re-test please?

        Show
        James Strachan
        added a comment - I think this is now fixed in 2.0.4 - could you re-test please?
        Claus Ibsen
        added a comment -

        Yeah I can now drop a xml file

        Show
        Claus Ibsen
        added a comment - Yeah I can now drop a xml file

          People

          • Assignee:
            James Strachan
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: