Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2.0
    • Component/s: JMX
    • Labels:
      None
    • Environment:
      1.1.83
    • Similar Issues:
      Show 9 results 

      Description

      I create a new Fuse project and use the spring archetype.

      I then copy message1.xml and adjust it a bit. So I have a 3rd message ready, I can drop in the data folder.

      I start the local CamelContext and attach the JMX to it.
      I then right click to enable tracing.
      And i drop in message3.xml file.

      No trace messages appear. And I find an exception in the error log.

        Activity

        Claus Ibsen
        added a comment -

        java.lang.reflect.UndeclaredThrowableException
        at $Proxy40.dumpAllTracedMessages(Unknown Source)
        at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.getTraceExchanges(CamelContextNode.java:358)
        at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.browseExchanges(CamelContextNode.java:344)
        at com.fusesource.ide.fabric.views.MessagesView.refresh(MessagesView.java:102)
        at com.fusesource.ide.fabric.views.MessagesView.setExchangeBrowser(MessagesView.java:191)
        at com.fusesource.ide.fabric.views.MessagesView$1.selectionChanged(MessagesView.java:90)
        at org.eclipse.ui.internal.AbstractSelectionService.fireSelection(AbstractSelectionService.java:156)
        at org.eclipse.ui.internal.AbstractSelectionService.setActivePart(AbstractSelectionService.java:282)
        at org.eclipse.ui.internal.WWinPartService.updateActivePart(WWinPartService.java:135)
        at org.eclipse.ui.internal.WWinPartService.access$0(WWinPartService.java:125)
        at org.eclipse.ui.internal.WWinPartService$WWinListener.partDeactivated(WWinPartService.java:50)
        at org.eclipse.ui.internal.PartListenerList2$4.run(PartListenerList2.java:115)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        at org.eclipse.core.runtime.Platform.run(Platform.java:888)
        at org.eclipse.ui.internal.PartListenerList2.fireEvent(PartListenerList2.java:55)
        at org.eclipse.ui.internal.PartListenerList2.firePartDeactivated(PartListenerList2.java:113)
        at org.eclipse.ui.internal.PartService.firePartDeactivated(PartService.java:242)
        at org.eclipse.ui.internal.PartService.setActivePart(PartService.java:300)
        at org.eclipse.ui.internal.WorkbenchPagePartList.fireActivePartChanged(WorkbenchPagePartList.java:57)
        at org.eclipse.ui.internal.PartList.setActivePart(PartList.java:136)
        at org.eclipse.ui.internal.WorkbenchPage.setActivePart(WorkbenchPage.java:3537)
        at org.eclipse.ui.internal.WorkbenchPage.requestActivation(WorkbenchPage.java:3077)
        at org.eclipse.ui.internal.PartPane.requestActivation(PartPane.java:279)
        at org.eclipse.ui.internal.PartPane.handleEvent(PartPane.java:237)
        at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
        at org.eclipse.swt.widgets.Display.sendEvent(Display.java:3783)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1375)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1398)
        at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1379)
        at org.eclipse.swt.widgets.Shell.setActiveControl(Shell.java:1355)
        at org.eclipse.swt.widgets.Control.sendMouseEvent(Control.java:3041)
        at org.eclipse.swt.widgets.Control.mouseEvent(Control.java:2249)
        at org.eclipse.swt.widgets.Composite.mouseEvent(Composite.java:878)
        at org.eclipse.swt.widgets.Control.mouseDown(Control.java:2259)
        at org.eclipse.swt.widgets.Tree.mouseDown(Tree.java:1942)
        at org.eclipse.swt.widgets.Display.windowProc(Display.java:4983)
        at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
        at org.eclipse.swt.widgets.Widget.callSuper(Widget.java:220)
        at org.eclipse.swt.widgets.Widget.windowSendEvent(Widget.java:1959)
        at org.eclipse.swt.widgets.Shell.windowSendEvent(Shell.java:2025)
        at org.eclipse.swt.widgets.Display.windowProc(Display.java:5047)
        at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method)
        at org.eclipse.swt.widgets.Display.applicationSendEvent(Display.java:4589)
        at org.eclipse.swt.widgets.Display.applicationProc(Display.java:4666)
        at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method)
        at org.eclipse.swt.internal.cocoa.NSApplication.sendEvent(NSApplication.java:115)
        at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3281)
        at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640)
        at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604)
        at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438)
        at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
        at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664)
        at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
        at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115)
        at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
        Caused by: java.rmi.UnmarshalException: error unmarshalling return; nested exception is:
        java.lang.ClassNotFoundException: org.apache.camel.fabric.FabricTracerEventMessage (no security manager: RMI class loader disabled)
        at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:178)
        at com.sun.jmx.remote.internal.PRef.invoke(Unknown Source)
        at javax.management.remote.rmi.RMIConnectionImpl_Stub.invoke(Unknown Source)
        at javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.invoke(RMIConnector.java:995)
        at javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:288)
        ... 67 more
        Caused by: java.lang.ClassNotFoundException: org.apache.camel.fabric.FabricTracerEventMessage (no security manager: RMI class loader disabled)
        at sun.rmi.server.LoaderHandler.loadClass(LoaderHandler.java:375)
        at sun.rmi.server.LoaderHandler.loadClass(LoaderHandler.java:165)
        at java.rmi.server.RMIClassLoader$2.loadClass(RMIClassLoader.java:620)
        at java.rmi.server.RMIClassLoader.loadClass(RMIClassLoader.java:247)
        at sun.rmi.server.MarshalInputStream.resolveClass(MarshalInputStream.java:197)
        at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1574)
        at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1495)
        at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1731)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1328)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350)
        at java.util.ArrayList.readObject(ArrayList.java:593)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:974)
        at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1848)
        at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1752)
        at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1328)
        at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350)
        at sun.rmi.server.UnicastRef.unmarshalValue(UnicastRef.java:306)
        at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:155)
        ... 71 more

        Show
        Claus Ibsen
        added a comment - java.lang.reflect.UndeclaredThrowableException at $Proxy40.dumpAllTracedMessages(Unknown Source) at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.getTraceExchanges(CamelContextNode.java:358) at com.fusesource.ide.fabric.camel.navigator.CamelContextNode.browseExchanges(CamelContextNode.java:344) at com.fusesource.ide.fabric.views.MessagesView.refresh(MessagesView.java:102) at com.fusesource.ide.fabric.views.MessagesView.setExchangeBrowser(MessagesView.java:191) at com.fusesource.ide.fabric.views.MessagesView$1.selectionChanged(MessagesView.java:90) at org.eclipse.ui.internal.AbstractSelectionService.fireSelection(AbstractSelectionService.java:156) at org.eclipse.ui.internal.AbstractSelectionService.setActivePart(AbstractSelectionService.java:282) at org.eclipse.ui.internal.WWinPartService.updateActivePart(WWinPartService.java:135) at org.eclipse.ui.internal.WWinPartService.access$0(WWinPartService.java:125) at org.eclipse.ui.internal.WWinPartService$WWinListener.partDeactivated(WWinPartService.java:50) at org.eclipse.ui.internal.PartListenerList2$4.run(PartListenerList2.java:115) at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42) at org.eclipse.core.runtime.Platform.run(Platform.java:888) at org.eclipse.ui.internal.PartListenerList2.fireEvent(PartListenerList2.java:55) at org.eclipse.ui.internal.PartListenerList2.firePartDeactivated(PartListenerList2.java:113) at org.eclipse.ui.internal.PartService.firePartDeactivated(PartService.java:242) at org.eclipse.ui.internal.PartService.setActivePart(PartService.java:300) at org.eclipse.ui.internal.WorkbenchPagePartList.fireActivePartChanged(WorkbenchPagePartList.java:57) at org.eclipse.ui.internal.PartList.setActivePart(PartList.java:136) at org.eclipse.ui.internal.WorkbenchPage.setActivePart(WorkbenchPage.java:3537) at org.eclipse.ui.internal.WorkbenchPage.requestActivation(WorkbenchPage.java:3077) at org.eclipse.ui.internal.PartPane.requestActivation(PartPane.java:279) at org.eclipse.ui.internal.PartPane.handleEvent(PartPane.java:237) at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84) at org.eclipse.swt.widgets.Display.sendEvent(Display.java:3783) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1375) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1398) at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1379) at org.eclipse.swt.widgets.Shell.setActiveControl(Shell.java:1355) at org.eclipse.swt.widgets.Control.sendMouseEvent(Control.java:3041) at org.eclipse.swt.widgets.Control.mouseEvent(Control.java:2249) at org.eclipse.swt.widgets.Composite.mouseEvent(Composite.java:878) at org.eclipse.swt.widgets.Control.mouseDown(Control.java:2259) at org.eclipse.swt.widgets.Tree.mouseDown(Tree.java:1942) at org.eclipse.swt.widgets.Display.windowProc(Display.java:4983) at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method) at org.eclipse.swt.widgets.Widget.callSuper(Widget.java:220) at org.eclipse.swt.widgets.Widget.windowSendEvent(Widget.java:1959) at org.eclipse.swt.widgets.Shell.windowSendEvent(Shell.java:2025) at org.eclipse.swt.widgets.Display.windowProc(Display.java:5047) at org.eclipse.swt.internal.cocoa.OS.objc_msgSendSuper(Native Method) at org.eclipse.swt.widgets.Display.applicationSendEvent(Display.java:4589) at org.eclipse.swt.widgets.Display.applicationProc(Display.java:4666) at org.eclipse.swt.internal.cocoa.OS.objc_msgSend(Native Method) at org.eclipse.swt.internal.cocoa.NSApplication.sendEvent(NSApplication.java:115) at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3281) at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2640) at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2604) at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2438) at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:671) at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332) at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:664) at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:115) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575) at org.eclipse.equinox.launcher.Main.run(Main.java:1408) Caused by: java.rmi.UnmarshalException: error unmarshalling return; nested exception is: java.lang.ClassNotFoundException: org.apache.camel.fabric.FabricTracerEventMessage (no security manager: RMI class loader disabled) at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:178) at com.sun.jmx.remote.internal.PRef.invoke(Unknown Source) at javax.management.remote.rmi.RMIConnectionImpl_Stub.invoke(Unknown Source) at javax.management.remote.rmi.RMIConnector$RemoteMBeanServerConnection.invoke(RMIConnector.java:995) at javax.management.MBeanServerInvocationHandler.invoke(MBeanServerInvocationHandler.java:288) ... 67 more Caused by: java.lang.ClassNotFoundException: org.apache.camel.fabric.FabricTracerEventMessage (no security manager: RMI class loader disabled) at sun.rmi.server.LoaderHandler.loadClass(LoaderHandler.java:375) at sun.rmi.server.LoaderHandler.loadClass(LoaderHandler.java:165) at java.rmi.server.RMIClassLoader$2.loadClass(RMIClassLoader.java:620) at java.rmi.server.RMIClassLoader.loadClass(RMIClassLoader.java:247) at sun.rmi.server.MarshalInputStream.resolveClass(MarshalInputStream.java:197) at java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1574) at java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1495) at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1731) at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1328) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350) at java.util.ArrayList.readObject(ArrayList.java:593) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at java.io.ObjectStreamClass.invokeReadObject(ObjectStreamClass.java:974) at java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1848) at java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1752) at java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1328) at java.io.ObjectInputStream.readObject(ObjectInputStream.java:350) at sun.rmi.server.UnicastRef.unmarshalValue(UnicastRef.java:306) at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:155) ... 71 more
        Claus Ibsen
        added a comment -

        Camel version: 2.7.1-fuse-00-27

        Show
        Claus Ibsen
        added a comment - Camel version: 2.7.1-fuse-00-27
        Claus Ibsen
        added a comment -

        Just for the record the fon/sample/camel-activemq-web. It uses fuse mr -39 version.

        Show
        Claus Ibsen
        added a comment - Just for the record the fon/sample/camel-activemq-web. It uses fuse mr -39 version.
        James Strachan
        added a comment -

        fixed in 1.1.84 onwards; we now include the .43 version of all the archetypes which fixes this issue (so the archetypes use recent camel)

        Show
        James Strachan
        added a comment - fixed in 1.1.84 onwards; we now include the .43 version of all the archetypes which fixes this issue (so the archetypes use recent camel)

          People

          • Assignee:
            James Strachan
            Reporter:
            Claus Ibsen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: