Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-291

Java DSL not supported by route editor

    Details

    • Type: Feature Request Feature Request
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Rejected
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Similar Issues:
      Show 7 results 

      Description

      The Apache and FuseSource documentation position the Java DSL as the primary DSL to use with Camel. The XML DSL is treated like an after thought if it is mentioned at all. Having a tool that prioritizes the XML DSL and ignores the Java DSL seems to be contradictory. If users have been following our documentation, they likely are using the Java DSL for their development projects, so our editor is not really going to fit with how they are using Camel.

        Activity

        James Strachan
        added a comment -

        Thats not really true; they are both peers. Folks tend to use XML or Java about 50-50.

        Support for Java + Scala DSLs is on the roadmap, but surely this is a new feature/improvement not a bug?

        Show
        James Strachan
        added a comment - Thats not really true; they are both peers. Folks tend to use XML or Java about 50-50. Support for Java + Scala DSLs is on the roadmap, but surely this is a new feature/improvement not a bug?
        Eric Johnson
        added a comment -

        I'd like to see some numbers to support the 50% claim. They may be "peers" but that is not how they are presented in the docs at Apache or FuseSource. The XML does not get equal attention, and it is typically treated as subordinate to the Java.

        When I mentioned that Talend's route editor supports the Java DSL Scott Cranton said something to the effect of "makes sense the Java DSL is the one that everyone uses."

        Either way leaving 50% of the audience unaddressed seems like mistake particularly when a weak competitor like Talend does address their needs.

        Show
        Eric Johnson
        added a comment - I'd like to see some numbers to support the 50% claim. They may be "peers" but that is not how they are presented in the docs at Apache or FuseSource. The XML does not get equal attention, and it is typically treated as subordinate to the Java. When I mentioned that Talend's route editor supports the Java DSL Scott Cranton said something to the effect of "makes sense the Java DSL is the one that everyone uses." Either way leaving 50% of the audience unaddressed seems like mistake particularly when a weak competitor like Talend does address their needs.
        Lars Heinemann
        added a comment -

        We do not plan to support Java DSL for the moment.

        Show
        Lars Heinemann
        added a comment - We do not plan to support Java DSL for the moment.

          People

          • Assignee:
            Lars Heinemann
            Reporter:
            Eric Johnson
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: