Fuse IDE
  1. Fuse IDE
  2. ECLIPSE-133

seems selecting nodes on the palette no longer immediately update the selected node in the Properties view

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.1
    • Component/s: Camel Editor
    • Labels:
      None
    • Similar Issues:
      Show 7 results 

      Description

      when giving a demo with a recent installation of Fuse IDE; I found when I selected a node in the outline view it updated the properties view; however when selecting nodes on the canvas it often got a little stuck, showing the old selected node's Properties, not the newly selected node

        Activity

        Lars Heinemann
        added a comment -

        Unable to reproduce that problem but I will keep an eye on this.

        Show
        Lars Heinemann
        added a comment - Unable to reproduce that problem but I will keep an eye on this.
        James Strachan
        added a comment -

        This bug affected 3.6.2 only; seems that for some reason AbstractPropertySection.setInput() was not being called any more after selections in the canvas were updated.

        Added a workaround with another listener on the part

        Show
        James Strachan
        added a comment - This bug affected 3.6.2 only; seems that for some reason AbstractPropertySection.setInput() was not being called any more after selections in the canvas were updated. Added a workaround with another listener on the part

          People

          • Assignee:
            Lars Heinemann
            Reporter:
            James Strachan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: