Uploaded image for project: 'Drools'
  1. Drools
  2. DROOLS-4563

Upgrade javax.validation from 1.0.0.GA to 2.0.1.Final

    Details

    • Type: Feature Request
    • Status: Resolved (View Workflow)
    • Priority: Optional
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 7.29.0.Final
    • Component/s: None
    • Labels:
      None
    • Sprint:
      2019 Week 41-43 (from Okt 7), 2019 Week 44-46 (from Okt 28)
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      To do the upgrade of javax.validation (PR) it is needed to check all GWT reps (uberfire, errai,wb etc) because the javax.validation version is not supported in these reps.
      The version upgrade is needed for spring-boot and quarkus - so it should be upgraded in kie-parent but overwritten in all poms of GWT reps that doesn't support this new version by the old version. It is thought to add a dependency overwite in the root pom in those repo's to overwrite it to use the original older version
      On the other hand existing overrides like this should be removed then.
      All reps should be examined if they have an override or if the need the old version.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                manaRH Marek Novotny
                Reporter:
                mbiarnes Michael Biarnes Kiefer
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: