Uploaded image for project: 'Drools'
  1. Drools
  2. DROOLS-380

Example 4.20 file logger newFileLogger

    Details

    • Type: Bug
    • Status: Resolved (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 6.0.0.Final
    • Fix Version/s: 6.2.0.Final
    • Component/s: None
    • Labels:
      None
    • Affects:
      Documentation (Ref Guide, User Guide, etc.)

      Description

      In the documentation [1] example 4.20 mention the following code snippet.

      KieRuntimeLogger logger = KieServices.Factory.get().newFileLogger(ksession, "logdir/mylogfile");

      However that doesn't compile. I believe is missing a .getLoggers() so the proper snippet, I believe, was intended as

      KieRuntimeLogger logger = KieServices.Factory.get().getLoggers().newFileLogger(ksession, "logdir/mylogfile");

      Ciao
      MM

      References:
      [1] http://docs.jboss.org/drools/release/6.0.0.Final/drools-docs/html_single/#d0e1904

        Gliffy Diagrams

          Activity


            People

            • Assignee:
              psiroky-redhat.com Petr Široký
              Reporter:
              tari_manga Matteo Mortari
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development