Uploaded image for project: 'Drools'
  1. Drools
  2. DROOLS-3370

Issue is with the invalid M2E metadata in the downstream kie-maven-plugin

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: Minor
    • Resolution: Duplicate Issue
    • Affects Version/s: 7.14.0.Final, 7.15.0.Final
    • Fix Version/s: 7.14.0.Final
    • Component/s: build
    • Labels:
      None
    • Environment:

      JBoss Developer Studio 12.0 and Eclipse 12

    • Story Points:
      8
    • Steps to Reproduce:
      Hide

      Go to JBoss Developer Studio 12 or Eclipse 12 and build a drools maven with kie-maven-plugin

      Show
      Go to JBoss Developer Studio 12 or Eclipse 12 and build a drools maven with kie-maven-plugin
    • Affects:
      Compatibility/Configuration
    • Docs QE Status:
      NEW
    • QE Status:
      NEW

      Description

      When you try to use the quick start from the catalog or create any kjar project the kie-maven-plugin is not recognised therefore project is not building by Eclipse, even if you try to build from command line and refresh, eclipse don't pick up forcing you to include a workaround in the pom file.

      <pluginManagement>
      <plugins>
      <!-This plugin's configuration is used to store Eclipse m2e settings only. It has no influence on the Maven build itself.->
      <plugin>
      <groupId>org.eclipse.m2e</groupId>
      <artifactId>lifecycle-mapping</artifactId>
      <version>1.0.0</version>
      <configuration>
      <lifecycleMappingMetadata>
      <pluginExecutions>
      <pluginExecution>
      <pluginExecutionFilter>
      <groupId>org.kie</groupId>
      <artifactId>
      kie-maven-plugin
      </artifactId>
      <versionRange>
      [7.14.0.Final,)
      </versionRange>
      <goals>
      <goal>build</goal>
      <goal>generateDMNModel</goal>
      </goals>
      </pluginExecutionFilter>
      <action>
      <ignore></ignore>
      </action>
      </pluginExecution>
      </pluginExecutions>
      </lifecycleMappingMetadata>
      </configuration>
      </plugin>
      </plugins>
      </pluginManagement>

      This is not necessary on other IDEs

      This will also affect customer which use workbench to start they project and pull this to eclipse later on.

      JBoss Developer Studio engineer pointed out this problem is an Issue is with the invalid M2E metadata in the downstream kie-maven-plugin as you can see in the jira below

      https://issues.jboss.org/browse/JBDS-4745

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  anstephe Ant Stephenson
                  Reporter:
                  pamenon Paulo Menon
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: