Uploaded image for project: 'Cloud Enablement'
  1. Cloud Enablement
  2. CLOUD-1697

[COMMON] MongoDB drive is incompatible with mongodb:latest image

    XMLWordPrintable

    Details

      Description

      Database images are now released in multiple parallel streams. It seems to be no problem for MySQL and Postgres as there is a single JDBC driver for all versions.

      Unfortunately it is not the case for MongoDB. Each version in SCL comes with a new driver (https://access.redhat.com/documentation/en-US/Red_Hat_Software_Collections/2/html/2.3_Release_Notes/chap-RHSCL.html#sect-RHSCL-Features) that are backward but not forward compatible (https://docs.mongodb.com/ecosystem/drivers/driver-compatibility-reference/#java-driver-compatibility)

      The version in EAP and JWS (and all other images) is 2.11.4. The mongodb is contains 2.4, 2.6 and 3.2 that is mapped to latest and is thus default.

      I believe we have to upgrade to the latest MongoDB driver.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  bdecoste William Decoste
                  Reporter:
                  jpechanec Jiri Pechanec
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: