@Inject @Delegate means something else in the case of a Decorator anyway (and there's no delegate in the case of an interceptor). Also, I cannot see why there cannot be two separate concerns:
a) Inject the bean (which in the case of an Interceptor/Decorator will inject the Interceptor/Decorator itself, they're beans too, nothing wrong with that)
b) Inject the target instance or delegate. Since we don't have a common term for interception or decoration we could have two distinct qualifiers:
@Inject @Intercepted Bean<?> bean; for interceptors
@Inject @Decorated Bean<?> bean; for decorators
One point against this would be the proliferation of annotations, but I think that using distinct annotations helps keeping the spec clear.