Uploaded image for project: 'Byteman'
  1. Byteman
  2. BYTEMAN-356

Allow running the full build on JDK9

    Details

    • Type: Task
    • Status: Closed (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 4.0.1
    • Component/s: None
    • Labels:
      None

      Description

      Currently some modules require JDK9, for obvious testing reasons.

      The documentation however is using versions of Asciidoctor and indirectly JRuby which will fail when run with Java 9, so it's currently not possible to run the full build with a single JVM.

      It should now be possible to update the documentation build to work fine on Java 9, making it more convenient to build the whole project.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

                People

                • Assignee:
                  sannegrinovero Sanne Grinovero
                  Reporter:
                  sannegrinovero Sanne Grinovero
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: