Uploaded image for project: 'BoxGrinder Build'
  1. BoxGrinder Build
  2. BGBUILD-349

"Use RbConfig instead of obsolete and deprecated Config" deprecation warning with Ruby 1.9.3

    Details

    • Type: Enhancement
    • Status: Resolved (View Workflow)
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 0.10.1
    • Component/s: CLI
    • Labels:
      None
    • Environment:

      Ubuntu Precise
      ruby 1.9.3p0 (2011-10-30 revision 33570) [x86_64-linux]
      rubygems 1.8.16

      Description

      Running boxgrinder-build from master with ruby 1.9.3 outputs "Use RbConfig instead of obsolete and deprecated Config"

      Patch attached.

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Assignee:
                msavy Marc Savy
                Reporter:
                rubiojr Sergio Rubio
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: