Application Server 7
  1. Application Server 7
  2. AS7-4405

JBAS011230: Could not load JAX-RS Application class

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Done
    • Affects Version/s: 7.1.1.Final
    • Fix Version/s: None
    • Component/s: Class Loading
    • Environment:
      Mac OS X, Apple JDK 1.6.29, JBoss AS 7.1.1.Final
    • Steps to Reproduce:

      Deploy the war attached with the forum question.

      Show
      Deploy the war attached with the forum question.
    • Similar Issues:
      Show 10 results 

      Description

      AS7 can't find a JAX-RS Application class deployed with the application.

      14:20:36,333 INFO org.jboss.as.server.deployment (MSC service thread 1-3) JBAS015876: Starting deployment of "jaxrs-basic"
      14:20:36,380 ERROR org.jboss.msc.service.fail (MSC service thread 1-4) MSC00001: Failed to start service jboss.deployment.unit.jaxrs-basic.POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit.jaxrs-basic.POST_MODULE: Failed to process phase POST_MODULE of deployment "jaxrs-basic"
      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:119) jboss-as-server-7.1.1.Final.jar:7.1.1.Final
      at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) jboss-msc-1.0.2.GA.jar:1.0.2.GA
      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) jboss-msc-1.0.2.GA.jar:1.0.2.GA
      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) JBAS011230: Could not load JAX-RS Application class
      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) JBAS011230: Could not load JAX-RS Application class
      at java.lang.Thread.run(Thread.java:662) JBAS011230: Could not load JAX-RS Application class
      Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: JBAS011230: Could not load JAX-RS Application class
      at org.jboss.as.jaxrs.deployment.JaxrsScanningProcessor.scan(JaxrsScanningProcessor.java:221)
      at org.jboss.as.jaxrs.deployment.JaxrsScanningProcessor.deploy(JaxrsScanningProcessor.java:101)
      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:113) jboss-as-server-7.1.1.Final.jar:7.1.1.Final
      ... 5 more
      Caused by: java.lang.ClassNotFoundException: edu.certification.abhijitsarkar.ocewsd.jaxrs.basic.CarApplication from [Module "deployment.jaxrs-basic:main" from Service Module Loader]
      at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
      at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
      at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
      at org.jboss.as.jaxrs.deployment.JaxrsScanningProcessor.scan(JaxrsScanningProcessor.java:217)
      ... 7 more

        Activity

        jaikiran pai
        added a comment -

        The attached application in the forum thread is just Java source files. Please add more details to the forum thread about the application packaging.

        Show
        jaikiran pai
        added a comment - The attached application in the forum thread is just Java source files. Please add more details to the forum thread about the application packaging.
        Abhijit Sarkar
        added a comment -

        Attached the actual artifact with the forum thread, complete with class files, dependencies and all.

        Show
        Abhijit Sarkar
        added a comment - Attached the actual artifact with the forum thread, complete with class files, dependencies and all.
        Abhijit Sarkar
        added a comment -

        The JBAS011230 error only comes if I deploy using the jboss-as-maven-plugin. The deployment completes successfully if I deploy manually from the admin console.
        I am going to close this defect because the issue for which it was created is resolved.

        Show
        Abhijit Sarkar
        added a comment - The JBAS011230 error only comes if I deploy using the jboss-as-maven-plugin. The deployment completes successfully if I deploy manually from the admin console. I am going to close this defect because the issue for which it was created is resolved.
        Abhijit Sarkar
        added a comment -

        The JBAS011230 error only comes if I deploy using the jboss-as-maven-plugin. The deployment completes successfully if I deploy manually from the admin console.

        Show
        Abhijit Sarkar
        added a comment - The JBAS011230 error only comes if I deploy using the jboss-as-maven-plugin. The deployment completes successfully if I deploy manually from the admin console.

          People

          • Assignee:
            David Lloyd
            Reporter:
            Abhijit Sarkar
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: