Application Server 7
  1. Application Server 7
  2. AS7-4114

datasource min/max pool size details not available via json/cli

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved (View Workflow)
    • Priority: Major Major
    • Resolution: Rejected
    • Affects Version/s: 7.1.0.Final
    • Fix Version/s: None
    • Component/s: REST
    • Labels:
    • Environment:
      DR13, cli/json interface.
    • Steps to Reproduce:

      Use cli to browse data with recursive/runtime both true but fields are undefined. The max/min pool sizes are available via localhost:9990/console/App.hmtl.

      /subsystem=datasources/data-source=H2DS/

      max-pool-size => undefined
      min-pool-size => undefined

      Show
      Use cli to browse data with recursive/runtime both true but fields are undefined. The max/min pool sizes are available via localhost:9990/console/App.hmtl. /subsystem=datasources/data-source=H2DS/ max-pool-size => undefined min-pool-size => undefined
    • Similar Issues:
      Show 10 results 

      Description

      Use cli to browse data with recursive/runtime both true but fields are undefined. The max/min pool sizes are available via localhost:9990/console/App.hmtl.

      /subsystem=datasources/data-source=H2DS/

      max-pool-size => undefined
      min-pool-size => undefined

        Activity

        Emanuel Muckenhuber
        added a comment -

        "undefined" means it's not configured, not sure if there is a default value which should be exposed instead. There is a "statistics" exposing additional metrics.

        Show
        Emanuel Muckenhuber
        added a comment - "undefined" means it's not configured, not sure if there is a default value which should be exposed instead. There is a "statistics" exposing additional metrics.
        Emanuel Muckenhuber
        added a comment -

        Assigning to Stefano, since i am not sure if this is a bug.

        Show
        Emanuel Muckenhuber
        added a comment - Assigning to Stefano, since i am not sure if this is a bug.
        Stefano Maestri
        added a comment -

        The description of the resource contains the default values. read-resource return only values if explicit set by the user. IOW "undefined" means that user has not defined any value and so defaults are used. Defaults can be get by read-resource-descrition

        Show
        Stefano Maestri
        added a comment - The description of the resource contains the default values. read-resource return only values if explicit set by the user. IOW "undefined" means that user has not defined any value and so defaults are used. Defaults can be get by read-resource-descrition
        Simeon Pinder
        added a comment -

        Note:
        So basically this looks like a misunderstanding between how the default values
        are defined for some objects in AS7. Instead of setting the default values in
        the object model itself as is the case in many places they are attaching a
        metadata description object where the default values are defined. This is not
        consistently done across all of the nodes or even the subsystems.

        In the AS7 administration console the default values are correctly displayed
        because they knew to populate the default values from the metadata(if
        undefined). I interpreted this as a bug when I requested the same data via cli
        and got undefined.

        In ER4.1 these values are available so this issue is no longer blocked.

        Show
        Simeon Pinder
        added a comment - Note: So basically this looks like a misunderstanding between how the default values are defined for some objects in AS7. Instead of setting the default values in the object model itself as is the case in many places they are attaching a metadata description object where the default values are defined. This is not consistently done across all of the nodes or even the subsystems. In the AS7 administration console the default values are correctly displayed because they knew to populate the default values from the metadata(if undefined). I interpreted this as a bug when I requested the same data via cli and got undefined. In ER4.1 these values are available so this issue is no longer blocked.

          People

          • Assignee:
            Stefano Maestri
            Reporter:
            Simeon Pinder
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: